summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-16 19:36:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-16 20:56:57 +0200
commit4da936898504bb823dd637553a2e5678a3cfea47 (patch)
tree7c3839cd0953522ef2828d97f6b37055c3b57d95 /dev-python/uvicorn
parentkernel-build.eclass: Enable py3.10 (diff)
downloadgentoo-4da936898504bb823dd637553a2e5678a3cfea47.tar.gz
gentoo-4da936898504bb823dd637553a2e5678a3cfea47.tar.bz2
gentoo-4da936898504bb823dd637553a2e5678a3cfea47.zip
dev-python/uvicorn: Add missing test-dep on python-dotenv
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/uvicorn-0.14.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/uvicorn/uvicorn-0.14.0-r1.ebuild b/dev-python/uvicorn/uvicorn-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..3901bfce5fee
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.14.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="https://www.uvicorn.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/asgiref-3.3.4[${PYTHON_USEDEP}]
+ >=dev-python/click-7[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing-extensions[${PYTHON_USEDEP}]' python3_7)
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/websockets-9.1[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # watchgod is not in the tree
+ sed -e '/^from uvicorn.supervisors.watchgodreload/d' \
+ -e 's/, WatchGodReload//' \
+ -i tests/supervisors/test_reload.py
+ distutils-r1_python_prepare_all
+}