summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-07-21 14:54:31 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-07-21 15:57:19 -0700
commit5b8eb450cb7077a0e0e8f04d8e39cfcfb6e9dbcf (patch)
tree28d9f4ed32d953dd9be893f0e5baf9e27edf0a60 /dev-python/unearth
parentdev-python/requests-wsgi-adapter: new package, add 0.4.1 (diff)
downloadgentoo-5b8eb450cb7077a0e0e8f04d8e39cfcfb6e9dbcf.tar.gz
gentoo-5b8eb450cb7077a0e0e8f04d8e39cfcfb6e9dbcf.tar.bz2
gentoo-5b8eb450cb7077a0e0e8f04d8e39cfcfb6e9dbcf.zip
dev-python/unearth: new package, add 0.10.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest1
-rw-r--r--dev-python/unearth/metadata.xml15
-rw-r--r--dev-python/unearth/unearth-0.10.0.ebuild33
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
new file mode 100644
index 000000000000..bf545b1dc31d
--- /dev/null
+++ b/dev-python/unearth/Manifest
@@ -0,0 +1 @@
+DIST unearth-0.10.0.tar.gz 270997 BLAKE2B 8b18df4616fc72025492aa187101bc1f338967b1738ef9ec33d16cbd906c1cf91c1b84e391538521b4a9d6ea40301eb0b7ed0926aa4e6c4d6ffc57401f9d78d9 SHA512 98799202939e1206b6fdd46eb61947c9f9f8068a6857f76aace8dd2c67a3fad9dd3b7a5232d7812b0dcd214c39a9e2a6fafbd18cbfeb9aa4c216571b88b3f131
diff --git a/dev-python/unearth/metadata.xml b/dev-python/unearth/metadata.xml
new file mode 100644
index 000000000000..112da0f56f24
--- /dev/null
+++ b/dev-python/unearth/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">unearth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/unearth/unearth-0.10.0.ebuild b/dev-python/unearth/unearth-0.10.0.ebuild
new file mode 100644
index 000000000000..313a864aa056
--- /dev/null
+++ b/dev-python/unearth/unearth-0.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest