summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-08 06:16:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-08 06:41:01 +0200
commitaf601a226b0c1b4753d980fe324801e63bbeb788 (patch)
tree72844b43a50842f39a8899553e0b0cf10211d663 /dev-python/uncertainties
parentdev-python/uncertainties: Remove old (diff)
downloadgentoo-af601a226b0c1b4753d980fe324801e63bbeb788.tar.gz
gentoo-af601a226b0c1b4753d980fe324801e63bbeb788.tar.bz2
gentoo-af601a226b0c1b4753d980fe324801e63bbeb788.zip
dev-python/uncertainties: Bump to 3.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/Manifest1
-rw-r--r--dev-python/uncertainties/uncertainties-3.2.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/uncertainties/Manifest b/dev-python/uncertainties/Manifest
index e17ca605b727..7d8d73d2822b 100644
--- a/dev-python/uncertainties/Manifest
+++ b/dev-python/uncertainties/Manifest
@@ -1 +1,2 @@
DIST uncertainties-3.2.1.tar.gz 143154 BLAKE2B 68a0e840878eed602666f1b315ea575f3ab07ca12555f6153801ffbb54b9b1ae8742e4d87c7cec9ec0ace505c4dd8aeb45d3a010663691db31145a146390c932 SHA512 4b1b1738bed60dddacaa0e7f6d8672e32c8282681c4f2f5222e26798150774a24349fb1a98011ff37dc990ab2dd271a3fff2abbc7a0279d499d08585df1b814f
+DIST uncertainties-3.2.2.tar.gz 143865 BLAKE2B 38f88ba147f2ef43749ddf2735fc26c1804e8acd504db2b8317abe69b37daded70b7e111edae1793dc3000d5bde207fe4156221d17c9284eb0006d3369efb367 SHA512 b78efc09cc572ecd24ead89db4136741429ab9032295c9e9050a79e14662b41c7537580f698e38d4ee1a36ae460ee22a463eeb473806a1f72246ab6868d950a3
diff --git a/dev-python/uncertainties/uncertainties-3.2.2.ebuild b/dev-python/uncertainties/uncertainties-3.2.2.ebuild
new file mode 100644
index 000000000000..2a213488261f
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="
+ https://pythonhosted.org/uncertainties/
+ https://github.com/lmfit/uncertainties/
+ https://pypi.org/project/uncertainties/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "numpy support" dev-python/numpy
+}