summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-13 06:21:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-13 06:46:12 +0200
commit04a91ca48772099b6f1033812c987710e090142a (patch)
treea1f0133490e447804480758dac409e7b0fc8b88c /dev-python/typeguard
parentdev-python/nodeenv: Bump to 1.8.0 (diff)
downloadgentoo-04a91ca48772099b6f1033812c987710e090142a.tar.gz
gentoo-04a91ca48772099b6f1033812c987710e090142a.tar.bz2
gentoo-04a91ca48772099b6f1033812c987710e090142a.zip
dev-python/typeguard: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-4.0.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index ade5ffe6b10b..6c9aa1736457 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1 +1,2 @@
DIST typeguard-3.0.2.tar.gz 58171 BLAKE2B d11b9592c191f131a48c8545a1ffbc4dcf4fc32f12dd0ba0bbab84c11ae1d6ba4cf6126fdc5d5b9b2ba81f07a3047f8328c7a8c29c1779238a04b12d4fe8b01c SHA512 a8f87494d4962cfa451ab266fb2958867acb677ec07acad0e8ccead16b9f3d59facffbe133de4e7808147caefb2b41c184b19bc82a812d041e90c3c1c1c0667a
+DIST typeguard-4.0.0.tar.gz 66064 BLAKE2B 250ef359fedb83df7573c9acb97f80fbf1d5b949505deb3d3757422aedadda65a106bf9533d858e13e2c49e0212a40a8604fa2edc8b24903e374a678985f4c85 SHA512 2acf8b9aabaa8d4cce75e1ff23aeae4d1445bdfc28044c74b8e96127b1e740287e5da89bd49bea92229ba5c02c7cec3b0e25126fa35eb5163b798b2087b1df6a
diff --git a/dev-python/typeguard/typeguard-4.0.0.ebuild b/dev-python/typeguard/typeguard-4.0.0.ebuild
new file mode 100644
index 000000000000..beefb022add6
--- /dev/null
+++ b/dev-python/typeguard/typeguard-4.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-3.6[${PYTHON_USEDEP}]
+ ' 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # the XFAIL test pass due to some package being installed
+ epytest -o xfail_strict=False
+}