summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-26 09:14:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-26 09:22:30 +0100
commit4cf2e96eb362ef6ae04c139ebec28d21f41095cc (patch)
tree7d4f9e397f69d50781749fcb6a8abf68d5f9b168 /dev-python/txaio
parentdev-python/hypothesis: Bump to 6.3.3 (diff)
downloadgentoo-4cf2e96eb362ef6ae04c139ebec28d21f41095cc.tar.gz
gentoo-4cf2e96eb362ef6ae04c139ebec28d21f41095cc.tar.bz2
gentoo-4cf2e96eb362ef6ae04c139ebec28d21f41095cc.zip
dev-python/txaio: Bump to 21.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/txaio')
-rw-r--r--dev-python/txaio/Manifest1
-rw-r--r--dev-python/txaio/txaio-21.2.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/txaio/Manifest b/dev-python/txaio/Manifest
index c5d717202de9..1ad2d623dc1e 100644
--- a/dev-python/txaio/Manifest
+++ b/dev-python/txaio/Manifest
@@ -1 +1,2 @@
DIST txaio-20.12.1.tar.gz 53200 BLAKE2B 0bbcf8a64fec668c2cf128a390779ca81033d0f43f02a341c46fc392254ff011df13a1456757e86dc5c4c15f18468698f4da85cc830fb2e52e4e620f7a8767ee SHA512 efde6115b8eccba94dce736fffe49f280ff49e9738f3299578cf41641c3b6f1deb5b1c0f0c8c6fbf85c8d8adbdc2d3f67aa256335d63a5977ac0bfacc98f909c
+DIST txaio-21.2.1.tar.gz 53383 BLAKE2B ff245c7e303a88e0e0f71bfa99ec5cfa2e6ec026e43e9477beb711cc753d73d4f49079727f9f86499779819fda74747edee00ebe22c0ac59c764c1403b983960 SHA512 762875b9c10304dab31dd54f7830f56b0cc26dd6e7a98c8faf57891a2810e36f53004833f872f0f51bad61cb62be033cfc228c99fd6aff60cd4dd2ae2f2e5c37
diff --git a/dev-python/txaio/txaio-21.2.1.ebuild b/dev-python/txaio/txaio-21.2.1.ebuild
new file mode 100644
index 000000000000..d4a805dd4f33
--- /dev/null
+++ b/dev-python/txaio/txaio-21.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
+HOMEPAGE="https://github.com/crossbario/txaio https://pypi.org/project/txaio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ >=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
+ )
+"
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinxcontrib-spelling-2.1.2' \
+ '>=dev-python/sphinx_rtd_theme-0.1.9'
+distutils_enable_tests pytest
+
+src_prepare() {
+ default_src_prepare
+ # Take out failing tests known to pass when run manually
+ # we certainly don't need to test "python setup.py sdist" here
+ rm "${S}/test/test_packaging.py" || die
+}