summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-08 12:19:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-08 12:21:35 +0200
commit1d8c3a3312912d65961b83c73462954fff164950 (patch)
tree15f1ffd87fbb9848173b6c4d77c1ec90a677f357 /dev-python/trio-websocket
parentdev-python/pdm-backend: Bump to 2.1.0 (diff)
downloadgentoo-1d8c3a3312912d65961b83c73462954fff164950.tar.gz
gentoo-1d8c3a3312912d65961b83c73462954fff164950.tar.bz2
gentoo-1d8c3a3312912d65961b83c73462954fff164950.zip
dev-python/trio-websocket: Bump to 0.10.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trio-websocket')
-rw-r--r--dev-python/trio-websocket/Manifest1
-rw-r--r--dev-python/trio-websocket/trio-websocket-0.10.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/trio-websocket/Manifest b/dev-python/trio-websocket/Manifest
index 9871bbeb8a6e..119224c7865c 100644
--- a/dev-python/trio-websocket/Manifest
+++ b/dev-python/trio-websocket/Manifest
@@ -1 +1,2 @@
DIST trio-websocket-0.10.2.gh.tar.gz 45025 BLAKE2B cc80f7b8e06bb88bef69c6326dd899a27523ea70e0ea10c8b02a26498102638c569ffe21e2b4e355f9c635d60ae8ae34664d311bf5fe286456e43e0f9c2ba481 SHA512 ad8d4facb153b59597ca7dac14dabe60ac8ca4331aa72df8120e01ec726e1f392a8167d070f72534eb735b5dbf4afe46e385c0e3a2dd250afa2280c6a5a0c863
+DIST trio-websocket-0.10.3.gh.tar.gz 45109 BLAKE2B 7adad8bd59b2350d7b8e50e88710c8b9844e8b34c712615e058a6045d575671043c527ac4330941431502affc7c307d61c1f9c1b328c579a622ff11ea79fbeb6 SHA512 8ff50030c9616ea8baa9627f229304fbb72528fcc97d1e5ead90acc3c7d683751c0d98e9c4f779d4d65fc765b00b6ec93b6d3384070a76fe18d3318af7afa975
diff --git a/dev-python/trio-websocket/trio-websocket-0.10.3.ebuild b/dev-python/trio-websocket/trio-websocket-0.10.3.ebuild
new file mode 100644
index 000000000000..8e735c733d60
--- /dev/null
+++ b/dev-python/trio-websocket/trio-websocket-0.10.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSocket client and server implementation for Python Trio"
+HOMEPAGE="
+ https://github.com/HyperionGray/trio-websocket/
+ https://pypi.org/project/trio-websocket/
+"
+SRC_URI="
+ https://github.com/HyperionGray/trio-websocket/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.11[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-0.14[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-trio-0.5.0[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p trio
+}