summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-21 20:30:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-21 20:41:09 +0300
commit0bc58aa795ad3fecc6f42e90197b6229ba2f59ff (patch)
treecfb68a6f0fc33363330238f69a97ca7a387f21c1 /dev-python/textdistance
parentdev-python/nuitka: add 1.0.5 (diff)
downloadgentoo-0bc58aa795ad3fecc6f42e90197b6229ba2f59ff.tar.gz
gentoo-0bc58aa795ad3fecc6f42e90197b6229ba2f59ff.tar.bz2
gentoo-0bc58aa795ad3fecc6f42e90197b6229ba2f59ff.zip
dev-python/textdistance: add 4.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest1
-rw-r--r--dev-python/textdistance/textdistance-4.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index 95327219d3aa..5285d235604b 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1 +1,2 @@
DIST textdistance-4.3.0.gh.tar.gz 45535 BLAKE2B e43ae62b0b7656a6c4f879b1d8e0c34ae6c83705d324aa99bb7ff6e2d0166faf1fed3ee7bc06602388c16c742a1983a4eaee143b09a7c371b9e941d53edca2b5 SHA512 30d68048b1f0b79e584f5f07731e03193af64cb2de3f52882c17154cc027f4ff8d590b994941bd5d62642d4da334ef0739d4bb65b6b12f039a1ee9aef154cde4
+DIST textdistance-4.4.0.gh.tar.gz 45542 BLAKE2B ae144cb7179b589f4106ea378e538e0d0240e6e2ac74dc5de8222ec2f671fcd09c4705cb5b30308fdb2f6071578d337c0f88983511229d9f7eb86c924d65bf56 SHA512 727696b76ee8fdfc9bcf028a93baad38882893f62612fa08725e5e8cd104b9450977e3682995c4aa7d997afcc8fdb73e3c72ea6c1a097a9a19dbce98957d4798
diff --git a/dev-python/textdistance/textdistance-4.4.0.ebuild b/dev-python/textdistance/textdistance-4.4.0.ebuild
new file mode 100644
index 000000000000..6b3f959525b4
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="https://github.com/life4/textdistance"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/abydos[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_external.py
+)