summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-02 10:47:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-02 10:47:23 +0100
commit7c9b6e89ec70ec9637802e8524507e25e624311f (patch)
tree0fca02ce73bdc201a5eda4043e88d27a5dc9d975 /dev-python/stripe
parentdev-python/botocore: Remove old (diff)
downloadgentoo-7c9b6e89ec70ec9637802e8524507e25e624311f.tar.gz
gentoo-7c9b6e89ec70ec9637802e8524507e25e624311f.tar.bz2
gentoo-7c9b6e89ec70ec9637802e8524507e25e624311f.zip
dev-python/stripe: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/stripe')
-rw-r--r--dev-python/stripe/Manifest1
-rw-r--r--dev-python/stripe/stripe-10.12.0.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/stripe/Manifest b/dev-python/stripe/Manifest
index 4d4a6f09d107..f5fc4613f8ed 100644
--- a/dev-python/stripe/Manifest
+++ b/dev-python/stripe/Manifest
@@ -1,3 +1,2 @@
-DIST stripe-10.12.0.tar.gz 1318680 BLAKE2B 0de2d108c6813d4ed0493b0e2b906a5d41f6b39b0f60fb2730fc3737b9f641d732e22c5ddf5e4e856b6bc5a1b312c10c9304467f29b5474bf8d6a9ca219f876d SHA512 0843cae0e1dd9a54604938a3ae5a28bb681e5166c2e800478c543b22b103626ac138ee999e468e909e3b5865754ed131af5a01287044603082f1f05329da45d3
DIST stripe-11.1.1.tar.gz 1340542 BLAKE2B 49e3884de5db95628efe1dd57685e9cced09d47015e1a7b8f9fa74ec0dd75f16d122bf1f7a579f6786b5886337d77cbf3f68770582431f4eb7dab3c09d2855e1 SHA512 13dd219559abfd38996eef7cf77c0278f58cccf744e34f139bf50068ec4ab18c896b444313103e8eab8eab05653ac6d3ba07a6d5734bde4cdd8cba10c4916be5
DIST stripe-11.2.0.tar.gz 1362386 BLAKE2B 56e22671886efe3e2b8d3c7f41402f5dcf4320e3ceea8d0ed9cf2813ba682ead62e9af796ef94d05f5eb18f678c55c36a1005902fdceca5ce9a9b5b4ac204193 SHA512 9344845d6b9b89886ea6ec2918b4ce53545141232aadaadfbf3f7bdd6522b1ee1bfe57f0145e69c0edeb66fb01dedb3a9fd7263410f7d2fbae7240c68ac87936
diff --git a/dev-python/stripe/stripe-10.12.0.ebuild b/dev-python/stripe/stripe-10.12.0.ebuild
deleted file mode 100644
index ffd0cdf1d337..000000000000
--- a/dev-python/stripe/stripe-10.12.0.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Stripe Python bindings"
-HOMEPAGE="
- https://github.com/stripe/stripe-python/
- https://pypi.org/project/stripe/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="telemetry"
-
-RDEPEND="
- >=dev-python/requests-2.20[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.5.0[${PYTHON_USEDEP}]
-"
-# please bump dev-util/stripe-mock dep to the latest version on every bump
-BDEPEND="
- test? (
- >=dev-util/stripe-mock-0.188.0
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/anyio[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- net-misc/curl
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-DOCS=( LONG_DESCRIPTION.rst CHANGELOG.md README.md )
-
-src_prepare() {
- distutils-r1_src_prepare
-
- if ! use telemetry; then
- sed -i -e '/enable_telemetry/s:True:False:' stripe/__init__.py || die
- fi
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # exception message mismatch with aiohttp-3.10.0
- "tests/test_integration.py::TestIntegration::test_async_timeout[asyncio-aiohttp]"
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest tests -p anyio -p pytest_mock
-}
-
-src_test() {
- local stripe_mock_port=12111
- local stripe_mock_max_port=12121
- local stripe_mock_logfile="${T}/stripe_mock_${EPYTHON}.log"
- # Try to start stripe-mock until we find a free port
- while [[ ${stripe_mock_port} -le ${stripe_mock_max_port} ]]; do
- ebegin "Trying to start stripe-mock on port ${stripe_mock_port}"
- stripe-mock --http-port "${stripe_mock_port}" &> "${stripe_mock_logfile}" &
- local stripe_mock_pid=${!}
- sleep 2
- # Did stripe-mock start?
- curl --fail -u "sk_test_123:" \
- "http://127.0.0.1:${stripe_mock_port}/v1/customers" &> /dev/null
- eend ${?} "Port ${stripe_mock_port} unavailable"
- if [[ ${?} -eq 0 ]]; then
- einfo "stripe-mock running on port ${stripe_mock_port}"
- break
- fi
- (( stripe_mock_port++ ))
- done
- if [[ ${stripe_mock_port} -gt ${stripe_mock_max_port} ]]; then
- eerror "Unable to start stripe-mock for tests"
- die "Please see the logfile located at: ${stripe_mock_logfile}"
- fi
-
- local -x STRIPE_MOCK_PORT=${stripe_mock_port}
- distutils-r1_src_test
-
- # Tear down stripe-mock
- kill "${stripe_mock_pid}" || die "Unable to stop stripe-mock"
-}