summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-11-23 05:56:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-11-23 05:56:13 +0000
commit07de1d1639bc66a9fb1318b65f44f751b7761ee2 (patch)
tree58487d0c8f5dabac82f564323d82913bb994fb08 /dev-python/sshtunnel
parentsys-apps/syd: add 3.3.4, drop 3.3.2 (diff)
downloadgentoo-07de1d1639bc66a9fb1318b65f44f751b7761ee2.tar.gz
gentoo-07de1d1639bc66a9fb1318b65f44f751b7761ee2.tar.bz2
gentoo-07de1d1639bc66a9fb1318b65f44f751b7761ee2.zip
dev-python/sshtunnel: add 0.4.0
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-python/sshtunnel')
-rw-r--r--dev-python/sshtunnel/Manifest1
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.4.0.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/sshtunnel/Manifest b/dev-python/sshtunnel/Manifest
index 90adee069cac..76a674d1b151 100644
--- a/dev-python/sshtunnel/Manifest
+++ b/dev-python/sshtunnel/Manifest
@@ -1 +1,2 @@
DIST sshtunnel-0.3.1.tar.gz 51392 BLAKE2B 9cf5c0e1f12489e482abf73e74d1a59bdc619b5248265add15744357ef49bf502e013b9d4494efff27e45817e0728f2cee3629f5cf21ba9849f564e84ac9c4a9 SHA512 5c24243cae959cf38f2cdcad4351950ca3abd1c6d289829b6603cd8e93b8d61480c4c7b3607bb38615854825c0bf08890c2362f79104c8bae7f9bf8e0931aa85
+DIST sshtunnel-0.4.0.tar.gz 62716 BLAKE2B 7ed2a1317d257be39c364b2a10acf53b14e701ddad13e35cbb47972625ac73da9ab68099886e36d4025c635537ecf016a52fa5e0064c2b2172abcde6192966d3 SHA512 c0e1fd9838369f3679cdf71f59994cdf658358bdbbb745cf4e765b4b82edfada966b131220c56e4b3bb88229607b17f2ce520bf3204d5aae8084dd4035024366
diff --git a/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild b/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild
new file mode 100644
index 000000000000..ec966060b5be
--- /dev/null
+++ b/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python SSH tunnels"
+HOMEPAGE="https://pypi.org/project/sshtunnel/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+
+RESTRICT="test"
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"