summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-12-08 11:52:03 +0300
committerDavid Seifert <soap@gentoo.org>2016-12-11 00:03:26 +0100
commit97e0194ab274ff452f40205a21f541320001f945 (patch)
treebcd9ceceaf79b2132621261e366742530019b563 /dev-python/rebulk
parentx11-misc/xcalib: Drop old (diff)
downloadgentoo-97e0194ab274ff452f40205a21f541320001f945.tar.gz
gentoo-97e0194ab274ff452f40205a21f541320001f945.tar.bz2
gentoo-97e0194ab274ff452f40205a21f541320001f945.zip
dev-python/rebulk: verbump to 0.8.2
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/rebulk')
-rw-r--r--dev-python/rebulk/Manifest1
-rw-r--r--dev-python/rebulk/rebulk-0.8.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rebulk/Manifest b/dev-python/rebulk/Manifest
index 19ae173137b9..15ebaa361f5c 100644
--- a/dev-python/rebulk/Manifest
+++ b/dev-python/rebulk/Manifest
@@ -1,2 +1,3 @@
DIST rebulk-0.7.2.tar.gz 254345 SHA256 ee4c75819c6d0eeedb531fb22c214e50f303ccc4703f27db1f993cd082ed5a20 SHA512 2855b6f754dd258e5e0ba8264cd6993c08fed141fb8b61f88b43beadea9acfcfeb54443c8708fa98de44f2c199dd900e6c9669dc616713dd61d873779f1df2f5 WHIRLPOOL a814772e5d34d6890b1435d652992a9b898435c4075619660351988d1ba955723a8440b8bde6a0c3e6547a465a9b040d085059a7938509a4edc9d7a21318148a
DIST rebulk-0.7.6.tar.gz 256070 SHA256 1357820b13460fc30ecdf58b7743b34da79f76bec954c21051da9eefab0e82cd SHA512 89dcaeecf559ab79c7d1d2f2f58d3f882e25517a95dacf2d1991d2035c40697cc0848bc28884b08ba7eb83d66ddc42b6f3d90133489ef45abef56ead260d95e5 WHIRLPOOL 466490082fbb1cbb57183ef9b5df7efd4449bb6dbff3fe91d730d9a4d44a9a85835caad4dece29be0be9f48485d6da2120db246c458858f507a706506da2211b
+DIST rebulk-0.8.2.tar.gz 257147 SHA256 8c09901bda7b79a21d46faf489d67d017aa54d38bdabdb53f824068a6640401a SHA512 7abbeb1974102db4846759de6c797b9fb0b81a6ffe573d8a7590342da8ed5b4c006258407540be8563d51fb36ac2a148132e879586a200a923cfe93dcc715bee WHIRLPOOL e50c3ca72801a11f9d926ea42572c910fba1660cdf6827bd2a00755beb808711dd2718a433c983bf20792bd7a05faf3820eb3477dbb639fe170dae68779a28c9
diff --git a/dev-python/rebulk/rebulk-0.8.2.ebuild b/dev-python/rebulk/rebulk-0.8.2.ebuild
new file mode 100644
index 000000000000..aac7c2b85ef4
--- /dev/null
+++ b/dev-python/rebulk/rebulk-0.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library that performs advanced searches in strings"
+HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.python.org/pypi/rebulk"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove base64-encoded zip archive with pytest.
+ rm runtests.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}