summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-20 09:12:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-20 09:26:43 +0100
commit7528f69808f2f33f548835fd599858fdc801fef5 (patch)
tree38e52e52a5d7a6d9bb68d05bc5ca9a4ded5dd6df /dev-python/pyusb
parentsys-apps/fwupd: Minor style fix (diff)
downloadgentoo-7528f69808f2f33f548835fd599858fdc801fef5.tar.gz
gentoo-7528f69808f2f33f548835fd599858fdc801fef5.tar.bz2
gentoo-7528f69808f2f33f548835fd599858fdc801fef5.zip
dev-python/pyusb: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyusb')
-rw-r--r--dev-python/pyusb/Manifest1
-rw-r--r--dev-python/pyusb/pyusb-1.1.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyusb/Manifest b/dev-python/pyusb/Manifest
index e2c488bba2b9..412b55c67a9a 100644
--- a/dev-python/pyusb/Manifest
+++ b/dev-python/pyusb/Manifest
@@ -1 +1,2 @@
DIST pyusb-1.1.0.tar.gz 78752 BLAKE2B ee541afedca7d5dca345c6addee2702ccb7408bb9a2d8b23fe1eb47f067a93309599894e364c0bdcef3e5348bd13cc39f240257efd4664679017f61b87853217 SHA512 0769670e6ebd8b31f2494258eca5d6e470ad3cb17663cc14b8b3a8136ea24caa23f86d81c60c501b88a9bc94b0de6a45aac43c6c5f140e65fd03a589b4d18179
+DIST pyusb-1.1.1.tar.gz 74746 BLAKE2B 795acafae3193e1a415baeb634554c8fdec3f4baa45a61a3eac9e1af4a84634cc540d421b7d8ad20142912fbef6ba53684e2e5b008e48f3e89406a493918ab20 SHA512 19aa82dcb9421d536063a975414855d1474f44b33dc4039e9a001be795061dbd60ed576acb605ae6bab7a0fe10834e5507408757546c7edcd50b43687a65a287
diff --git a/dev-python/pyusb/pyusb-1.1.1.ebuild b/dev-python/pyusb/pyusb-1.1.1.ebuild
new file mode 100644
index 000000000000..33c5549aa1aa
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="https://pyusb.github.io/pyusb/ https://pypi.org/project/pyusb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+DOCS=( README.rst docs/tutorial.rst )
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
+}