summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-09 12:17:08 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-09 12:21:09 +0100
commit39953c8d360240f216ef9017cb61af9897ba3d2c (patch)
tree5f96ca594a7f9076f8b1e9ce1c28fd1aa387f035 /dev-python/pytrie
parentmedia-sound/qsynth: bump to 0.6.1 (diff)
downloadgentoo-39953c8d360240f216ef9017cb61af9897ba3d2c.tar.gz
gentoo-39953c8d360240f216ef9017cb61af9897ba3d2c.tar.bz2
gentoo-39953c8d360240f216ef9017cb61af9897ba3d2c.zip
dev-python/pytrie: Modernize, add tests, py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytrie')
-rw-r--r--dev-python/pytrie/pytrie-0.3.1-r1.ebuild (renamed from dev-python/pytrie/pytrie-0.3.1.ebuild)12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pytrie/pytrie-0.3.1.ebuild b/dev-python/pytrie/pytrie-0.3.1-r1.ebuild
index 565ed0863459..412387da3573 100644
--- a/dev-python/pytrie/pytrie-0.3.1.ebuild
+++ b/dev-python/pytrie/pytrie-0.3.1-r1.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
MY_PN="PyTrie"
MY_P="${MY_PN}-${PV}"
-
DESCRIPTION="A pure Python implementation of the trie data structure"
HOMEPAGE="https://github.com/gsakkis/pytrie/ https://pypi.org/project/PyTrie/"
SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-DEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
-S="${WORKDIR}/${MY_P}"
+distutils_enable_tests setup.py