summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2018-03-23 16:38:10 +0100
committerHanno <hanno@gentoo.org>2018-03-23 16:38:10 +0100
commit725e5b419312236149de5ba2377af69f501051ef (patch)
tree45c7bba9476d893086e9abbaf5afce02a9e798d3 /dev-python/python-recaptcha/python-recaptcha-2.0.1.ebuild
parentx11-drivers/nvidia-drivers: Old. (diff)
downloadgentoo-725e5b419312236149de5ba2377af69f501051ef.tar.gz
gentoo-725e5b419312236149de5ba2377af69f501051ef.tar.bz2
gentoo-725e5b419312236149de5ba2377af69f501051ef.zip
dev-python/python-recaptcha: Version bump.
Namespace workaround no longer needed. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/python-recaptcha/python-recaptcha-2.0.1.ebuild')
-rw-r--r--dev-python/python-recaptcha/python-recaptcha-2.0.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-recaptcha/python-recaptcha-2.0.1.ebuild b/dev-python/python-recaptcha/python-recaptcha-2.0.1.ebuild
new file mode 100644
index 000000000000..12afe927a4cc
--- /dev/null
+++ b/dev-python/python-recaptcha/python-recaptcha-2.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for reCAPTCHA and reCAPTCHA Mailhide"
+HOMEPAGE="https://github.com/redhat-infosec/python-recaptcha"
+SRC_URI="https://github.com/redhat-infosec/python-recaptcha/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !dev-python/recaptcha-client"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"