summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNowa Ammerlaan <nowa@gentoo.org>2025-01-02 15:45:12 +0100
committerNowa Ammerlaan <nowa@gentoo.org>2025-01-02 16:19:54 +0100
commit56448645616a5eeb9be79617297f6d9353633f02 (patch)
tree4af38011013f6dd00c0d8428c0632f661707b6f5 /dev-python/python-lsp-black
parentdev-python/python-lsp-server: patch and enable python 3.13 (diff)
downloadgentoo-56448645616a5eeb9be79617297f6d9353633f02.tar.gz
gentoo-56448645616a5eeb9be79617297f6d9353633f02.tar.bz2
gentoo-56448645616a5eeb9be79617297f6d9353633f02.zip
dev-python/python-lsp-black: enable py3.13
Signed-off-by: Nowa Ammerlaan <nowa@gentoo.org>
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-2.0.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/python-lsp-black-2.0.0-r1.ebuild b/dev-python/python-lsp-black/python-lsp-black-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..3357a36a48a9
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-2.0.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-black/
+ https://pypi.org/project/python-lsp-black/
+"
+SRC_URI="
+ https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/black-23.11.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ !!<dev-python/python-lsp-black-2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}