summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-04-21 18:16:20 -0700
committerZac Medico <zmedico@gentoo.org>2020-04-21 18:17:51 -0700
commitcb8a46a709ebda063ebc71b6c84f19d39648e98d (patch)
tree76d7ca05871e435f75590abf0139d2227df5af21 /dev-python/python-engineio
parentnet-vpn/tailscale-0.98_p0: Version bump (diff)
downloadgentoo-cb8a46a709ebda063ebc71b6c84f19d39648e98d.tar.gz
gentoo-cb8a46a709ebda063ebc71b6c84f19d39648e98d.tar.bz2
gentoo-cb8a46a709ebda063ebc71b6c84f19d39648e98d.zip
dev-python/python-engineio: Bump to version 3.12.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-3.12.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index cb21223c609a..95c436548753 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1 +1,2 @@
DIST python-engineio-2.2.0.tar.gz 22137 BLAKE2B 5e864a4cb2bc5048f459f98e24894bf263caedaf58ce3225dbb216fc5f4722efbaf7f346c39869daf485debff1479db254add66f6f256066ed26a11a8be196b3 SHA512 8e601c583bea21b37fc673bf92e3b40d6f3ded7068e7b103111b60d6677195e67338398934a270dacc8621b040e52d32eb9652e15607c7be69b6c50a8d19eaf2
+DIST python-engineio-3.12.1.tar.gz 37158 BLAKE2B a3f75b0ec197248029a2a257eee7694298d916bc444705df7a941e8106d09e5bc802cd612c88e526883083730797e4835e13db93121714a701af17d894ac53cf SHA512 f81012e264025dc24845986e67c7d19d46048e072a409483a130630e07efb84e831e188d3f277dd0f7d26351015009afcef0d2058bb19dacee68d6c56837fa1d
diff --git a/dev-python/python-engineio/python-engineio-3.12.1.ebuild b/dev-python/python-engineio/python-engineio-3.12.1.ebuild
new file mode 100644
index 000000000000..c22628414e8f
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-3.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://python-engineio.readthedocs.org/ https://github.com/miguelgrinberg/python-engineio/ https://pypi.org/project/python-engineio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}