summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-11 19:42:49 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-12 00:11:19 +0200
commitc83aa6801ca7a94ece44c5b0636d5693a67295b4 (patch)
tree8607bf299b527fa610a1ba7cb0fd73a49103f39f /dev-python/pytest
parentdev-python/pytest: Add PyPy test fix from Debian (diff)
downloadgentoo-c83aa6801ca7a94ece44c5b0636d5693a67295b4.tar.gz
gentoo-c83aa6801ca7a94ece44c5b0636d5693a67295b4.tar.bz2
gentoo-c83aa6801ca7a94ece44c5b0636d5693a67295b4.zip
dev-python/pytest: Disable hanging py3.5+ tests
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-3.4.2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/pytest/pytest-3.4.2.ebuild b/dev-python/pytest/pytest-3.4.2.ebuild
index 9fb19f1d81bf..ed3fc47c722f 100644
--- a/dev-python/pytest/pytest-3.4.2.ebuild
+++ b/dev-python/pytest/pytest-3.4.2.ebuild
@@ -64,6 +64,11 @@ python_prepare_all() {
sed -i -e 's:test_wrapped_getfuncargnames_patching:_&:' \
testing/python/integration.py || die
+ # those tests appear to hang with python3.5+; TODO: investigate why
+ sed -i -e 's:test_runtest_location_shown_before_test_starts:_&:' \
+ testing/test_terminal.py || die
+ sed -i -e 's:test_trial_pdb:_&:' testing/test_unittest.py || die
+
distutils-r1_python_prepare_all
}