summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-30 16:03:19 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-13 21:22:00 +0300
commit8c07649004ae8acdc4ab1ce59020f26c0eb6a4c4 (patch)
tree48c598634f99c43df9272e8f2e9e9cabb3fb0752 /dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
parentsci-libs/Shapely: current maintainer has git access, p-m not needed (diff)
downloadgentoo-8c07649004ae8acdc4ab1ce59020f26c0eb6a4c4.tar.gz
gentoo-8c07649004ae8acdc4ab1ce59020f26c0eb6a4c4.tar.bz2
gentoo-8c07649004ae8acdc4ab1ce59020f26c0eb6a4c4.zip
dev-python/pytest-qt: bug fix in testsuite, add py3.9
https://github.com/pytest-dev/pytest-qt/issues/314 https://github.com/pytest-dev/pytest-qt/pull/315 Closes: https://bugs.gentoo.org/738264 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/17335 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pytest-qt/pytest-qt-3.3.0.ebuild')
-rw-r--r--dev-python/pytest-qt/pytest-qt-3.3.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
index 1a43c9248d65..55715700f9e8 100644
--- a/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -19,7 +19,13 @@ KEYWORDS="~amd64 ~x86"
DEPEND="dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]"
-PATCHES=( "${FILESDIR}/${P}-skip-show-window-test.patch" )
+# Patch 1 skips a test that does not work inside the emerge environment:
+# pytestqt.exceptions.TimeoutError: widget <PyQt5.QtWidgets.QWidget object at 0x7f57d8527af8> not activated in 1000 ms.
+# Patch 2 fixes upstream bug 314
+PATCHES=(
+ "${FILESDIR}/${P}-skip-show-window-test.patch"
+ "${FILESDIR}/${P}-fix-file-match-test.patch"
+)
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/sphinx_rtd_theme