summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-17 18:07:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-17 18:39:16 +0200
commitc71cdd5db2edd0c3704a69dd1babb39dc61a434a (patch)
tree0581ac213121cfa2fafa60265fca8701a2541797 /dev-python/pytest-import-check
parentdev-lang/luau: bump to 0.634 (diff)
downloadgentoo-c71cdd5db2edd0c3704a69dd1babb39dc61a434a.tar.gz
gentoo-c71cdd5db2edd0c3704a69dd1babb39dc61a434a.tar.bz2
gentoo-c71cdd5db2edd0c3704a69dd1babb39dc61a434a.zip
dev-python/pytest-import-check: Bump to 0.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-import-check')
-rw-r--r--dev-python/pytest-import-check/Manifest1
-rw-r--r--dev-python/pytest-import-check/pytest-import-check-0.0.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-import-check/Manifest b/dev-python/pytest-import-check/Manifest
index 474e5f6fe7f0..19d91bc2b2b8 100644
--- a/dev-python/pytest-import-check/Manifest
+++ b/dev-python/pytest-import-check/Manifest
@@ -1,2 +1,3 @@
DIST pytest_import_check-0.0.1.tar.gz 3019 BLAKE2B 7e34c3aa7b59b1c3af2eccd336cfa6e6b33ac596648c36c1fef647eb9d4f24e560b865fd8b58191f5ae94463f199f855c701f00d48912c73ee8474dfbc32d0b5 SHA512 e582af2017531318bd95acea7c96050a3f5f6373a4c1deeb7aa290e67a068bc46c398279a72dee5ef34c2585ccad75a7d9e74011335b845e86bcb1e9a1adaa2b
DIST pytest_import_check-0.0.2.tar.gz 16309 BLAKE2B 94e6f9d316194f6765a38ddc97ecb4a9df7d4413077e0f9a1d638b0535920e4d379f2cc538f102176e10cdd54b4b535531e0e9bf02c42c7c085b02a82c3f1a56 SHA512 fd2a5e0bb55d2cb0a3e8d0c6281f05996a4213ffa554636e02660882281af5aa43d759b801853b272b9b572b4c7de6c3c659861f4c4b780907eb8b0e6ec802e1
+DIST pytest_import_check-0.0.3.tar.gz 16993 BLAKE2B c0d9ccff18f46b4331ba455fec3e4353084769be631f81e56bf8f0fce374cbc3b9e5ef16e3527f7d39e2b6f46ea7e26b88ffd4197487575b14ee607f94389045 SHA512 4618bc4f5988480f712d0a5dcf7dc2743520a454e5b32beb225f04afeb70235a65bfc27c5a30dbdf248429b844a64edd4a0af805eaa720ba5658aa7dccf8fbb4
diff --git a/dev-python/pytest-import-check/pytest-import-check-0.0.3.ebuild b/dev-python/pytest-import-check/pytest-import-check-0.0.3.ebuild
new file mode 100644
index 000000000000..6b72cb2ba34c
--- /dev/null
+++ b/dev-python/pytest-import-check/pytest-import-check-0.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to check whether Python modules can be imported"
+HOMEPAGE="
+ https://github.com/projg2/pytest-import-check/
+ https://pypi.org/project/pytest-import-check/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-8.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_import_check.plugin
+ epytest
+}