summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-03 23:23:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-15 01:21:29 +0200
commitcce27e36f3e4df3354d6a96339e5d011c519296a (patch)
tree9897d980ebac44e5dd398ea09719b18055970eec /dev-python/pytables
parentdev-python/numpy: Drop superfluous calls to python_is_python3 (diff)
downloadgentoo-cce27e36f3e4df3354d6a96339e5d011c519296a.tar.gz
gentoo-cce27e36f3e4df3354d6a96339e5d011c519296a.tar.bz2
gentoo-cce27e36f3e4df3354d6a96339e5d011c519296a.zip
dev-python/pytables: Drop superfluous calls to python_is_python3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/pytables-3.4.4.ebuild8
-rw-r--r--dev-python/pytables/pytables-3.6.1.ebuild4
2 files changed, 0 insertions, 12 deletions
diff --git a/dev-python/pytables/pytables-3.4.4.ebuild b/dev-python/pytables/pytables-3.4.4.ebuild
index 9a5ed1e38117..f1f8a63e8be7 100644
--- a/dev-python/pytables/pytables-3.4.4.ebuild
+++ b/dev-python/pytables/pytables-3.4.4.ebuild
@@ -51,14 +51,6 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS}"
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
python_test() {
cd "${BUILD_DIR}"/lib* || die
${EPYTHON} tables/tests/test_all.py || die
diff --git a/dev-python/pytables/pytables-3.6.1.ebuild b/dev-python/pytables/pytables-3.6.1.ebuild
index 0406c688685c..0d24b5b1d06e 100644
--- a/dev-python/pytables/pytables-3.6.1.ebuild
+++ b/dev-python/pytables/pytables-3.6.1.ebuild
@@ -52,10 +52,6 @@ python_prepare_all() {
}
python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS}"
- append-cflags -fno-strict-aliasing
- fi
distutils-r1_python_compile -j1
}