summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-26 01:14:25 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-26 01:23:32 +0200
commit9de01c8e147ed2759b0572d0fef024956384e27d (patch)
tree9ca1d14ce387fa050d139dab07240fad72747c2e /dev-python/pysrt
parentdev-python/pysrt: add Python 3.7, PyPy{,3}, don't run coverage tests (diff)
downloadgentoo-9de01c8e147ed2759b0572d0fef024956384e27d.tar.gz
gentoo-9de01c8e147ed2759b0572d0fef024956384e27d.tar.bz2
gentoo-9de01c8e147ed2759b0572d0fef024956384e27d.zip
dev-python/pysrt: sync live ebuild with 1.1.1-r1
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/pysrt-9999.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/dev-python/pysrt/pysrt-9999.ebuild b/dev-python/pysrt/pysrt-9999.ebuild
index bda2f23780fd..5ceb7f709502 100644
--- a/dev-python/pysrt/pysrt-9999.ebuild
+++ b/dev-python/pysrt/pysrt-9999.ebuild
@@ -1,30 +1,35 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=7
-inherit distutils-r1 git-r3
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
DESCRIPTION="Python library used to edit or create SubRip files"
HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
-EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/nose[coverage(+),${PYTHON_USEDEP}]
${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
)
"
python_test() {
- nosetests --with-coverage --cover-package=pysrt \
- || die "Tests failed under ${EPYTHON}"
+ nosetests -v || die "Tests failed under ${EPYTHON}"
}