summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-01 18:39:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-01 18:42:12 +0200
commitaac23853e57398582e4df2e45f88eb4960274f5d (patch)
treeb916ba50e1f783f5e6eae36dde5fc06a50845792 /dev-python/pylint
parentdev-python/pypiserver: Remove old (diff)
downloadgentoo-aac23853e57398582e4df2e45f88eb4960274f5d.tar.gz
gentoo-aac23853e57398582e4df2e45f88eb4960274f5d.tar.bz2
gentoo-aac23853e57398582e4df2e45f88eb4960274f5d.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.17.4.ebuild84
2 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 70af9b432c4c..79f6872324fb 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1 @@
-DIST pylint-2.17.4.gh.tar.gz 1411540 BLAKE2B ad8e5dfcd378e2c87f59fc7bad36c504296555ea0174d0f6fd3e59c04eb5610ee0a40257cd4d457418808b55efef8ffef7ca5d6e7da946323cb32e34cf5f0d67 SHA512 0232f0badf7124db549e768f5d158e7b7728fb34893726b5c3a0f599e201a18069118f0aab2aed0b0e1d47c0d4d37cec72d9c1c489ec5c3c316a53431ccf35a5
DIST pylint-2.17.5.gh.tar.gz 1413718 BLAKE2B 7ba0a6cb78cdef5f16e80d98d1b02f41ae700c44365de26a0a650b60fe95b4b806e36786d16ec50ed5c78c8b86c13afe8e7fe215dd938df654c2883d5493d318 SHA512 431e722d027b03f1b657841ccaba43233961e810aecfe1a679e3ba4ba92fea94f28524195861a6fd4fe6fc6267a1af6489b9b69e5e30f919ac3a476fd35698ec
diff --git a/dev-python/pylint/pylint-2.17.4.ebuild b/dev-python/pylint/pylint-2.17.4.ebuild
deleted file mode 100644
index bcacb8364284..000000000000
--- a/dev-python/pylint/pylint-2.17.4.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/pylint-dev/pylint/
-"
-SRC_URI="
- https://github.com/pylint-dev/pylint/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
-# Adjust dep bounds!
-RDEPEND="
- <dev-python/astroid-2.17[${PYTHON_USEDEP}]
- >=dev-python/astroid-2.15.4[${PYTHON_USEDEP}]
- >=dev-python/dill-0.3.6[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- rm -rf pylint || die
-
- local EPYTEST_DESELECT=(
- # TODO
- 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- 'tests/test_functional.py::test_functional[shadowed_import]'
- tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
- tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
- tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
-
- # apparently fragile, needs unpickleable plugin
- tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable
- )
- local EPYTEST_IGNORE=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
- epytest
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}