summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 10:11:09 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 10:33:03 +0100
commitcd0cd8654556e0ca4b87d03bbb60762f7aeeba49 (patch)
tree44353e5f637f00b15ab7286c6a318e9b692d3e64 /dev-python/pyjwt
parentdev-python/pyflakes: Add python3.5 support (diff)
downloadgentoo-cd0cd8654556e0ca4b87d03bbb60762f7aeeba49.tar.gz
gentoo-cd0cd8654556e0ca4b87d03bbb60762f7aeeba49.tar.bz2
gentoo-cd0cd8654556e0ca4b87d03bbb60762f7aeeba49.zip
dev-python/pyjwt: Add python3.5 support
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest2
-rw-r--r--dev-python/pyjwt/pyjwt-1.4.0.ebuild10
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index a395d4cddeaa..8188866d8970 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1,2 +1,2 @@
+DIST PyJWT-1.4.0.tar.gz 34613 SHA256 e1b2386cfad541445b1d43e480b02ca37ec57259fd1a23e79415b57ba5d8a694 SHA512 1664864c0566dbeb1e35c977d30e746c844605e1ce90becda8771c4ff8a8dbad911075f5a41f445d405552b2d61bbb1e86011564027f68c6c4fcd332cf704ff1 WHIRLPOOL 4ebd7291b9a9676559703794acdaf0dd2bd1033dd649ef8068bca85fa7ef6ab444e834910fa78b16c15cf324dd4a470d9b40ecdccdb5fdaca7568ab096dc9a8e
DIST pyjwt-1.3.0.tar.gz 61828 SHA256 fc230244ec4e4014d6eeae894ac852e820a4c843dc209d4f77e76d564f46ee49 SHA512 2b7ab0702bb71041bb7280e0e51958fb6bfb9b8c70ac99e24c4ce92e6d37d0432f3323634dceb371dd47c6b380687b2df92bb6ae9f4df555e4938a9a2f76e0f3 WHIRLPOOL bc4a0d79d37b60aa018607d715e2dc7e275ade326994df9a4ac7e0e70e37c11c7bec4d70d292bedf6f18be8d7aa09f826b80d14a532fd00c650d417223285daf
-DIST pyjwt-1.4.0.tar.gz 34613 SHA256 e1b2386cfad541445b1d43e480b02ca37ec57259fd1a23e79415b57ba5d8a694 SHA512 1664864c0566dbeb1e35c977d30e746c844605e1ce90becda8771c4ff8a8dbad911075f5a41f445d405552b2d61bbb1e86011564027f68c6c4fcd332cf704ff1 WHIRLPOOL 4ebd7291b9a9676559703794acdaf0dd2bd1033dd649ef8068bca85fa7ef6ab444e834910fa78b16c15cf324dd4a470d9b40ecdccdb5fdaca7568ab096dc9a8e
diff --git a/dev-python/pyjwt/pyjwt-1.4.0.ebuild b/dev-python/pyjwt/pyjwt-1.4.0.ebuild
index 2ac6634bbbaf..33ee5991bbe4 100644
--- a/dev-python/pyjwt/pyjwt-1.4.0.ebuild
+++ b/dev-python/pyjwt/pyjwt-1.4.0.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-inherit eutils distutils-r1
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
+
+inherit distutils-r1 eutils
MY_PN="PyJWT"
DESCRIPTION="JSON Web Token implementation in Python"
HOMEPAGE="https://github.com/progrium/pyjwt https://pypi.python.org/pypi/PyJWT/"
-#SRC_URI="https://github.com/progrium/${P}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
LICENSE=" MIT"
SLOT="0"