summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-24 06:09:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-24 07:14:04 +0200
commit007d17467f110c19c14c2f1e89c946abf00e6915 (patch)
tree03e9e5e0029dbd307f6a451bf244f3578e5e0918 /dev-python/pyicu
parentdev-python/dill: Bump to 0.3.6 (diff)
downloadgentoo-007d17467f110c19c14c2f1e89c946abf00e6915.tar.gz
gentoo-007d17467f110c19c14c2f1e89c946abf00e6915.tar.bz2
gentoo-007d17467f110c19c14c2f1e89c946abf00e6915.zip
dev-python/pyicu: Bump to 2.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyicu')
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/pyicu-2.10.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index d580319529e8..4d77e04ecd8b 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1 +1,2 @@
+DIST pyicu-v2.10.tar.bz2 192789 BLAKE2B 824b83177b420bb78633a2d7b93bdcc781ec87ea105e7441be59547c6f56fadf292aa331decac96f095672a4d2741d709ed32dec4841b070bc056e7f0f8d65d0 SHA512 8f752ba97fc5ffc3004591826b47bd76c9b99d73a3784b2bba746cb611969a47a98971c89fe0b35dc817fd14b93b1bf0e85f4bf23986af22bcf5401485899c9e
DIST pyicu-v2.9.tar.bz2 243533 BLAKE2B c2ea32f69637e2d12a57ded96b570ba7fd41c92aed4a0dea36ebe5c224b80fa8d1672251f8218e0a35d463957ab4291cff778c3e690f0763e465dc6f0a1af26d SHA512 f10025afe1a0de5a1726c3d4aaec5b10ba62064c33205117efe643185dcd3560e8971b600606e9699269cca795477bf86ed2f9e604e9c0e04bb75a86f31cd114
diff --git a/dev-python/pyicu/pyicu-2.10.ebuild b/dev-python/pyicu/pyicu-2.10.ebuild
new file mode 100644
index 000000000000..28f46b028f2e
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/
+"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ dev-libs/icu:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest