summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 22:43:48 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 22:46:30 +0200
commitc89876eb36c1c4d0ab77550b1564f03c715e2e1e (patch)
treed5a810e3fe0a0915891e5736a2038eaee70de96e /dev-python/pyhamcrest
parentxfce-base/thunar: Remove old (diff)
downloadgentoo-c89876eb36c1c4d0ab77550b1564f03c715e2e1e.tar.gz
gentoo-c89876eb36c1c4d0ab77550b1564f03c715e2e1e.tar.bz2
gentoo-c89876eb36c1c4d0ab77550b1564f03c715e2e1e.zip
dev-python/pyhamcrest: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest1
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index 935a77e4c4af..deaea02caa3a 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1,3 +1,2 @@
DIST PyHamcrest-1.10.1.gh.tar.gz 59019 BLAKE2B 1a090533ea8fe2dff9ad232b2e6dbf82841c38f3699e57750e2309b06a46e70ae5a9c7d087baf06de53e17323a5e36edee1a01d7a4442374d15b76a7723c2031 SHA512 f7e79f7d26c4c6add042052e451898bbf5adf21b05a234cc62bce890d68f5997693b042a9daf136f7026040a8ab7bf28b829288417b947973dcb959bf613a37b
-DIST PyHamcrest-1.9.0.gh.tar.gz 57650 BLAKE2B c497688f03ec3b072d8ab076fc096a442d5cbbd94493eae57779879ccb6f281477aeeb7f7a67e539442010e60194f9f04a6deddd1d2267e9743742b45433f124 SHA512 3a878637ed5138365416c170871a63640f089047b723c7ec8db893dd716c0b1cdad16a98584700405693b954af7d4868a8543d1a3fc58ded22b493c8c61661b4
DIST PyHamcrest-2.0.2.gh.tar.gz 55491 BLAKE2B 749f227b8cb1180a64e24cdbf97b6f610b9871b21215a761642d19fdd43ad8e175718b12cfb0de2cdb5c6ae8c3c5271e04b7c3b489e01ac689769e24202ece56 SHA512 d6e510ca1e6533b425b424d411e23c4ee2a6bad2d635695e4e68f991fbdc57269c3a433361e431cb5dda7891278951d5de7a05f5c1c167714eecdaf74644d1c8
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
deleted file mode 100644
index 6c7080cb324b..000000000000
--- a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6..9} )
-
-inherit distutils-r1
-
-MY_PN="PyHamcrest"
-
-DESCRIPTION="Hamcrest framework for matcher objects"
-HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
-SRC_URI="https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz -> ${MY_PN}-${PV}.gh.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.6[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx doc \
- dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- # enables coverage testing which we don't want
- rm pytest.ini || die
-
- # Known test failures. Remove them for now.
- rm tests/hamcrest_unit_test/base_description_test.py || die "removing test #1 failed"
- rm tests/hamcrest_unit_test/core/is_test.py || die "removing test #2 failed"
- rm tests/hamcrest_unit_test/core/isinstanceof_test.py || die "removing test #3 failed"
-
- # These fail on HPPA. Drop them too.
- if use hppa; then
- rm tests/hamcrest_unit_test/base_matcher_test.py || die "removing test #4 failed"
- rm tests/hamcrest_unit_test/core/described_as_test.py || die "removing test #5 failed"
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv || die "Tests failed under ${EPYTHON}"
- "${EPYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}