summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-24 14:34:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-24 14:35:12 +0200
commitf1c296ac784183126fc5707fe08742b1a8e302d4 (patch)
treefc4004b7906d556525f9696d9216f2c764a7e24a /dev-python/pycurl
parentnet-p2p/airdcpp-webclient: remove old (diff)
downloadgentoo-f1c296ac784183126fc5707fe08742b1a8e302d4.tar.gz
gentoo-f1c296ac784183126fc5707fe08742b1a8e302d4.tar.bz2
gentoo-f1c296ac784183126fc5707fe08742b1a8e302d4.zip
dev-python/pycurl: Force building using distutils
Bug: https://bugs.gentoo.org/738798 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/pycurl-7.43.0.5.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/pycurl/pycurl-7.43.0.5.ebuild b/dev-python/pycurl/pycurl-7.43.0.5.ebuild
index d4876adf5b11..208be0af1b8f 100644
--- a/dev-python/pycurl/pycurl-7.43.0.5.ebuild
+++ b/dev-python/pycurl/pycurl-7.43.0.5.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=manual
# The selftests fail with pypy, and urlgrabber segfaults for me.
PYTHON_COMPAT=( python3_{6,7,8,9} )
@@ -54,6 +55,8 @@ PATCHES=(
python_prepare_all() {
sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+ # disable automagic use of setuptools
+ sed -e 's:import wheel:raise ImportError:' -i setup.py || die
# these tests are broken with newer versions of bottle
sed -e 's:test.*_invalid_utf8:_&:' -i tests/getinfo_test.py || die
distutils-r1_python_prepare_all