summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-11-17 17:56:23 -0500
committerMike Gilbert <floppym@gentoo.org>2019-11-17 17:58:59 -0500
commit534369f45a07089970f310a90978057da74504eb (patch)
tree931c0beea9fe10c7ef3ff58c19a115c358c83a2c /dev-python/pycparser/pycparser-2.19-r1.ebuild
parentdev-libs/busybee: drop old EAPI (diff)
downloadgentoo-534369f45a07089970f310a90978057da74504eb.tar.gz
gentoo-534369f45a07089970f310a90978057da74504eb.tar.bz2
gentoo-534369f45a07089970f310a90978057da74504eb.zip
dev-python/pycparser: ensure modules are compiled
Package-Manager: Portage-2.3.79_p3, Repoman-2.3.18_p2 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/pycparser/pycparser-2.19-r1.ebuild')
-rw-r--r--dev-python/pycparser/pycparser-2.19-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pycparser/pycparser-2.19-r1.ebuild b/dev-python/pycparser/pycparser-2.19-r1.ebuild
new file mode 100644
index 000000000000..3b8d5a5df7df
--- /dev/null
+++ b/dev-python/pycparser/pycparser-2.19-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="C parser and AST generator written in Python"
+HOMEPAGE="https://github.com/eliben/pycparser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove the original files to guarantee their regen
+ rm pycparser/{c_ast,lextab,yacctab}.py || die
+
+ # kill sys.path manipulations to force the tests to use built files
+ sed -i -e '/sys\.path/d' tests/*.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # change workdir to avoid '.' import
+ nosetests -v -w tests || die
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # setup.py generates {c_ast,lextab,yacctab}.py with bytecode disabled.
+ python_optimize
+}