summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-27 07:15:26 +0100
committerSam James <sam@gentoo.org>2023-06-27 07:15:38 +0100
commit85a7ad9b41b2d8c9e9c5b3a5e27910282ba86e49 (patch)
tree0917e53138dbee27fa672f7338f1385de26fb08b /dev-python/pooch
parentsys-kernel/linux-headers: add 6.4 (diff)
downloadgentoo-85a7ad9b41b2d8c9e9c5b3a5e27910282ba86e49.tar.gz
gentoo-85a7ad9b41b2d8c9e9c5b3a5e27910282ba86e49.tar.bz2
gentoo-85a7ad9b41b2d8c9e9c5b3a5e27910282ba86e49.zip
dev-python/pooch: enable py3.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/pooch-1.7.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pooch/pooch-1.7.0.ebuild b/dev-python/pooch/pooch-1.7.0.ebuild
index 911a4181b52c..a2379d26b6bd 100644
--- a/dev-python/pooch/pooch-1.7.0.ebuild
+++ b/dev-python/pooch/pooch-1.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
@@ -29,7 +29,6 @@ BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/pytest-localftpserver[${PYTHON_USEDEP}]
dev-python/tqdm[${PYTHON_USEDEP}]
)
"
@@ -39,6 +38,9 @@ EPYTEST_DESELECT=(
pooch/tests/test_core.py::test_check_availability_invalid_downloader
pooch/tests/test_core.py::test_load_registry_from_doi
pooch/tests/test_core.py::test_load_registry_from_doi_zenodo_with_slash
+ # dev-python/pytest-localftpserver -> dev-python/pyftpdlib has py3.12 issues
+ # https://github.com/giampaolo/pyftpdlib/issues/560#issuecomment-971377238
+ pooch/tests/test_core.py::test_check_availability_on_ftp
pooch/tests/test_downloaders.py::test_invalid_doi_repository
pooch/tests/test_downloaders.py::test_doi_url_not_found
pooch/tests/test_downloaders.py::test_figshare_url_file_not_found