summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-19 06:50:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-19 06:57:56 +0200
commitec70c80498bdf2131708ca912f0c715caff6b45e (patch)
treea4bfba8fe280fa8724deae314004ff6509e34a7e /dev-python/platformdirs
parentdev-python/asteval: Bump to 0.9.30 (diff)
downloadgentoo-ec70c80498bdf2131708ca912f0c715caff6b45e.tar.gz
gentoo-ec70c80498bdf2131708ca912f0c715caff6b45e.tar.bz2
gentoo-ec70c80498bdf2131708ca912f0c715caff6b45e.zip
dev-python/platformdirs: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-3.6.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 8624778afa19..c1a5b85513da 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1,3 +1,4 @@
DIST platformdirs-3.5.1.tar.gz 17164 BLAKE2B 7d9aeff02000b75a028e6f75dc4793e53bbe72b5fc069482d5790d9280a92b801dffca847fe64513b8ee3d24b5639681cb1cfcb1f97d85e8e996c7f6cbca2f71 SHA512 e3aa38bc943f9dc709dfaa3c6fe9e11f3b33d4263d1d41f7349d9926db2e41a36dd43c74ea2175ad89b107601f2dffded0f45e7703b9cb8ca9739945dee3c6fb
DIST platformdirs-3.5.2.tar.gz 17775 BLAKE2B 2ec36d1efb77cdf5d247dd7e3a731389f4125d9fdb6b3edf8b3c4c1c87f9336ee38ef7923f284193b4105121e3e5ea5d87e07f153ec6eb395f1dca0573282e16 SHA512 68066aa85b44c37cbe602610371866dd5b7e9b6787b27d51379ecb347d27abdabf57da26ae622268df29fd3cfa9892f977060990a5235fb651a694d1a3fd7d99
DIST platformdirs-3.5.3.tar.gz 17780 BLAKE2B bffcc38623022f24175d1cb7097e65f73208b5aefedba2a22a584ea63fafeafe9ec7fd3701f903890282bca33dfd03d11c3070327f7efe474eb64ed548448ac6 SHA512 2510f7e5a260df6ac5d111e80a513979060f7a77c038b79d6db4b42d196ffb8bbacb2db6e986186926931bb28fec867404ed4e23eb3268b6abdbf318d79baa69
+DIST platformdirs-3.6.0.tar.gz 18187 BLAKE2B 22e6da0d01e3862518052eba5a20efca4bb365619a6acdbd7722367b5acc4724a06f3baa8a57e8ba2d1957d9be35fd0074db89cc5732596e05bd44c2b5248a41 SHA512 f760e0fec11ca040e2138fc6c8423f9a39106fdf1f41811a19598892fbda31dc75cdeb4138e6355d87bbeeb879fd42ac2eee6e337e6093e59150ee26e73e4d41
diff --git a/dev-python/platformdirs/platformdirs-3.6.0.ebuild b/dev-python/platformdirs/platformdirs-3.6.0.ebuild
new file mode 100644
index 000000000000..70e821d796fb
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-3.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}