summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-03 04:13:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-03 05:20:16 +0100
commitadf3d73d808cfd8bb6781f515cdd9488c3b2362a (patch)
treed04ab5c0dd02b688b1fa9405b6fdc70672b04f75 /dev-python/pipx
parentdev-python/fsspec: Bump to 2023.12.0 (diff)
downloadgentoo-adf3d73d808cfd8bb6781f515cdd9488c3b2362a.tar.gz
gentoo-adf3d73d808cfd8bb6781f515cdd9488c3b2362a.tar.bz2
gentoo-adf3d73d808cfd8bb6781f515cdd9488c3b2362a.zip
dev-python/pipx: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pipx')
-rw-r--r--dev-python/pipx/Manifest1
-rw-r--r--dev-python/pipx/pipx-1.3.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pipx/Manifest b/dev-python/pipx/Manifest
index d4056e247853..c9497f921f1c 100644
--- a/dev-python/pipx/Manifest
+++ b/dev-python/pipx/Manifest
@@ -1 +1,2 @@
DIST pipx-1.2.1.gh.tar.gz 405585 BLAKE2B ca24ffd9fe3657549d149aa6e24f85ef2d7ae0832f94605a0a52ecd255232c3bd1b553e61be805bd80c9d54586a4e6e9e156db17c5bb901e24069828f0716594 SHA512 93a0d67de9540584987be126d4e28a2628beefba99e15936369c948dc29fb7f11745413ef3f0ace5586b4456ed8554103bcd5079079bc0a34babc02823f7f9d3
+DIST pipx-1.3.1.gh.tar.gz 418883 BLAKE2B f9c0ee11eb1e92efb4fc1600d56383ff838b3d97200a4baef32d1221e05c65aeb9d9cc48477dbdf85cb596f44423fb746abd97be2861724ca0de433aa6794d68 SHA512 9ee91efa142f72fbe962d05a21ad3bfcef4d401a20078863bb65a932b3598efff95cd707ec27cca1d4c82f3396270c7162d4cb1407ad1d40b2e477aa0b3c02fc
diff --git a/dev-python/pipx/pipx-1.3.1.ebuild b/dev-python/pipx/pipx-1.3.1.ebuild
new file mode 100644
index 000000000000..01daa9316fba
--- /dev/null
+++ b/dev-python/pipx/pipx-1.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Install and Run Python Applications in Isolated Environments"
+HOMEPAGE="
+ https://pypi.org/project/pipx/
+ https://pypa.github.io/pipx/
+"
+# no tests in sdist
+SRC_URI="
+ https://github.com/pypa/pipx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/argcomplete-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/userpath-1.9.0[${PYTHON_USEDEP}]
+"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --net-pypiserver
+}