summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-26 06:19:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-26 06:19:54 +0200
commit810d42314987636c57918d91e6409895cc5e23d2 (patch)
tree859eaf3ea7185b0b5221e13de490bf346014291f /dev-python/paginate
parentdev-python/pyparsing: Bump to 3.1.4 (diff)
downloadgentoo-810d42314987636c57918d91e6409895cc5e23d2.tar.gz
gentoo-810d42314987636c57918d91e6409895cc5e23d2.tar.bz2
gentoo-810d42314987636c57918d91e6409895cc5e23d2.zip
dev-python/paginate: Bump to 0.5.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paginate')
-rw-r--r--dev-python/paginate/Manifest1
-rw-r--r--dev-python/paginate/paginate-0.5.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/paginate/Manifest b/dev-python/paginate/Manifest
index 2289fdca573a..c0603a99ca12 100644
--- a/dev-python/paginate/Manifest
+++ b/dev-python/paginate/Manifest
@@ -1 +1,2 @@
DIST paginate-0.5.6.gh.tar.gz 15567 BLAKE2B c5b60ad43c61a918c618668b345cae82e5e61516aa73130339830db8b8d1d49d271ed24bf9379c570ef8ae9de0844ff8e088820c7e128e1e6e77a03427c06596 SHA512 64d7d1a9952dc8ae5894113c381a9cdca5395477091d794774ed770f1e1dfb6a5d88a7bd07cc4fca0c0c8f708656261f3160b315af6f86ecc5b7f46e1d639150
+DIST paginate-0.5.7.gh.tar.gz 16751 BLAKE2B bc109607876b214572707cbfda25e35b57c80fc6947838ff31feab9299f3a51ad91df44dc5b5040583084a64609cb3156c9c344906f3b719cf55832a2bbe348d SHA512 f0e1957ff7b9177f052ae985e103b93acd55c9390bc06479926ccdc288343720214a02d2de46700caceb07d934d33baabdc364fc8cbd997a29fb433383892405
diff --git a/dev-python/paginate/paginate-0.5.7.ebuild b/dev-python/paginate/paginate-0.5.7.ebuild
new file mode 100644
index 000000000000..e89c4cd893d9
--- /dev/null
+++ b/dev-python/paginate/paginate-0.5.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Divides large result sets into pages for easier browsing"
+HOMEPAGE="
+ https://github.com/Pylons/paginate/
+ https://pypi.org/project/paginate/
+"
+SRC_URI="
+ https://github.com/Pylons/paginate/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ python3.13)
+ ;&
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # these tests assume that dict is not sliceable
+ # https://github.com/Pylons/paginate/issues/19
+ tests/test_paginate.py::test_wrong_collection
+ tests/test_paginate.py::TestCollectionTypes::test_unsliceable_sequence3
+ )
+ ;;
+ esac
+
+ epytest
+}