summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 11:19:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 11:24:50 +0200
commit6f67055873ba8a07af7092c99325c9a2b40371bc (patch)
treedf7a649d8c689e5ffdab84af62f72c5cc8ac4f12 /dev-python/openpyxl
parentdev-python/et_xmlfile: Enable py3.11 (diff)
downloadgentoo-6f67055873ba8a07af7092c99325c9a2b40371bc.tar.gz
gentoo-6f67055873ba8a07af7092c99325c9a2b40371bc.tar.bz2
gentoo-6f67055873ba8a07af7092c99325c9a2b40371bc.zip
dev-python/openpyxl: Bump to 3.0.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/Manifest1
-rw-r--r--dev-python/openpyxl/openpyxl-3.0.10.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/openpyxl/Manifest b/dev-python/openpyxl/Manifest
index d669466fb729..2473ba1d4a18 100644
--- a/dev-python/openpyxl/Manifest
+++ b/dev-python/openpyxl/Manifest
@@ -1 +1,2 @@
+DIST openpyxl-3.0.10.tar.bz2 2427596 BLAKE2B 7422e15d1852d7ce6fa7547cdde2ff6cbe02ccdc13d0a48272cc0f544ade8283833ccfd006d83cca0ac719b2354af76e220522655cadad8dda11bc39ddb6de30 SHA512 1b06ed6c17ab15c277a46cb83db030ba37424a718962070728a8723db50e3fb6a77078b26e04aaee4a924686cacb2c6413742f7aa3533c0f9ecfabca9757af56
DIST openpyxl-3.0.9.tar.bz2 2428070 BLAKE2B b62133ee8e732142428b4f9eaf158e6f33daf314ed1ad620d921ad10265d1db93e2fcef807a61b3277e96f245392fd19b48da715eb0c560c882683fb1407f7a1 SHA512 33c313c842a43003a6e056b58869652377bef74bcaf267c50cc49f6abb7caa8a1b4e8f3b400a054f7d1776e03763ebebc984d331520bd63411ec4acfa8a03787
diff --git a/dev-python/openpyxl/openpyxl-3.0.10.ebuild b/dev-python/openpyxl/openpyxl-3.0.10.ebuild
new file mode 100644
index 000000000000..b6a1aa4d603d
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.0.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="
+ https://openpyxl.readthedocs.io/en/stable/
+ https://foss.heptapod.net/openpyxl/openpyxl/
+"
+SRC_URI="
+ https://foss.heptapod.net/openpyxl/openpyxl/-/archive/${PV}/${P}.tar.bz2
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest