summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-07 22:31:03 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-07 22:31:03 +0200
commitf39437d2998602f3414155c5459f9a313585102e (patch)
tree39a4d016530ba32f1638260ade8a15ab11acf131 /dev-python/openapi-spec-validator
parentdev-python/openapi-schema-validator: Remove old (diff)
downloadgentoo-f39437d2998602f3414155c5459f9a313585102e.tar.gz
gentoo-f39437d2998602f3414155c5459f9a313585102e.tar.bz2
gentoo-f39437d2998602f3414155c5459f9a313585102e.zip
dev-python/openapi-spec-validator: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-spec-validator')
-rw-r--r--dev-python/openapi-spec-validator/Manifest1
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.5.0-r1.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/openapi-spec-validator/Manifest b/dev-python/openapi-spec-validator/Manifest
index 3fb79bab0d3e..11f061375f0a 100644
--- a/dev-python/openapi-spec-validator/Manifest
+++ b/dev-python/openapi-spec-validator/Manifest
@@ -1,3 +1,2 @@
DIST openapi-spec-validator-0.4.0.gh.tar.gz 46051 BLAKE2B 43a1458ab1801700261f750e49d45b0cb4d02f1c17a16943b5232836061e0e1466fc973343bbd4bf7a8669b682bd6761cb905fdfb3b80c0b9720253cc2d5a926 SHA512 d2eaf22c75e72eb5061a916eb37b13179a5ba65eb8a00ec42e81c6b4168239bc8613388f2d77ce35113d260385b175280d8863a3deedf18ea5aa93a79f058419
-DIST openapi-spec-validator-0.5.0.gh.tar.gz 39173 BLAKE2B 0c9ac1617423b2f1983e1036b5bfddba3388ace454bb3df743d9d5fe62708fabd54ff4373b77901fc78e7e761d0cc059132a557e73bf5095618fd6f1f074bcfe SHA512 728f600962b493a0e6914d5ac662cda107929630e26b95fb3d5749579d90d278073f5b5d69445cbe90e4c3edbc2ee5de34045f34003a8c75a3d5a33df52cb1fc
DIST openapi-spec-validator-0.5.1.gh.tar.gz 39539 BLAKE2B 66adbed2c85527f89e510d5cbc11ccf05f23546191e2677a1c34f7545d2e975dda37f1c53e988e37cf526663053ac0176567137273e3be9156b24deda89db6c1 SHA512 b70a2f926d889fec9d4fd26c51e1fbbeb5e75f13449d2d0205b1b7edb12ab2ba49e4cac69426f782ca3a4430c79a6de8f66b4aad2fc552bcfcf7005e866522ff
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.0-r1.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.0-r1.ebuild
deleted file mode 100644
index 058e1fc7c0ec..000000000000
--- a/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.0-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
-HOMEPAGE="
- https://github.com/p1c2u/openapi-spec-validator/
- https://pypi.org/project/openapi-spec-validator/
-"
-SRC_URI="
- https://github.com/p1c2u/openapi-spec-validator/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
- >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
- >=dev-python/openapi-schema-validator-0.3.2[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_resources-5.8.0[${PYTHON_USEDEP}]
- ' 3.8)
-"
-
-PATCHES=(
- # https://github.com/p1c2u/openapi-spec-validator/pull/174
- "${FILESDIR}/${P}-std-importlib.patch"
-)
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Internet
- tests/integration/test_shortcuts.py::TestPetstoreV2Example
- tests/integration/test_shortcuts.py::TestApiV2WithExampe
- tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
- tests/integration/test_shortcuts.py::TestPetstoreExample
- tests/integration/test_shortcuts.py::TestRemoteValidatev2SpecUrl
- tests/integration/test_shortcuts.py::TestRemoteValidatev30SpecUrl
- tests/integration/test_shortcuts.py::TestApiWithExample
- tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
- tests/integration/test_validate.py::TestPetstoreExample
- tests/integration/test_validate.py::TestApiWithExample
- tests/integration/test_validate.py::TestPetstoreExpandedExample
- tests/integration/validation/test_validators.py
-)
-
-src_prepare() {
- sed -i -e '/--cov/d' pyproject.toml || die
- distutils-r1_src_prepare
-}