summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-30 08:55:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-30 09:34:54 +0200
commit8dd6b590c4cc016623a82e69d9430fe9f70b92ae (patch)
tree921163ac1db9df9705e72a87744d10aea48fde95 /dev-python/numpydoc
parentdev-python/jaraco-envs: Bump to 2.4.0 (diff)
downloadgentoo-8dd6b590c4cc016623a82e69d9430fe9f70b92ae.tar.gz
gentoo-8dd6b590c4cc016623a82e69d9430fe9f70b92ae.tar.bz2
gentoo-8dd6b590c4cc016623a82e69d9430fe9f70b92ae.zip
dev-python/numpydoc: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numpydoc')
-rw-r--r--dev-python/numpydoc/Manifest1
-rw-r--r--dev-python/numpydoc/numpydoc-1.3.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/numpydoc/Manifest b/dev-python/numpydoc/Manifest
index 805c3bd793bd..c1e37772fd84 100644
--- a/dev-python/numpydoc/Manifest
+++ b/dev-python/numpydoc/Manifest
@@ -1,2 +1,3 @@
DIST numpydoc-1.2.1.tar.gz 70350 BLAKE2B f693436efa8e95527e4d7d20676b1f3e563369190a71cc4e2cc8ec38b65ad500f3e0e8a4e89ce48ebd3bf1190c8fff1ead05cc22dbbf80fdf147b9996b2b5add SHA512 439ff422d46ea8eaa26bd14ac41f8d64638d8df081a3b889eaadceafbde64f2a091f6363d0565759618d60c4fe869d8f62ec0878d45674022056058621048d0e
DIST numpydoc-1.2.tar.gz 69659 BLAKE2B e5483ad3d6d82e9ff51d2d7cdc36c75407361059a696047f1d0fb7d3307c36ee056e8c0b9eb45fc11e4d341350c1b1dd021d60252055154c6907942e549b9555 SHA512 b8ea82a947c7fca9d02c2083f6040f2a1a115400e43257fd6ce7ac9b1b174d22ed7723053b87893d6bff8f47a625932297c884e853be4e00d3ae2262ad0161cf
+DIST numpydoc-1.3.0.gh.tar.gz 70243 BLAKE2B 64b6550bffb644945972e38eb9783ca0a81478c9c9f8aac9d0a91b5871fcc9470d55533ebd4cbe287cf7ade2f355b05e4a31e8558e4fff3a836b37ed33027b13 SHA512 ba6b77fba590a9cb97562e9325db98d3423e39eeca6f28975960bc3ac9c83922ad9c47ecb92c2e2ec359f050304225fc204347708cf699cb40074eaefaa29e41
diff --git a/dev-python/numpydoc/numpydoc-1.3.0.ebuild b/dev-python/numpydoc/numpydoc-1.3.0.ebuild
new file mode 100644
index 000000000000..8b2f2b65ba40
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-1.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="
+ https://numpydoc.readthedocs.io/en/latest/
+ https://github.com/numpy/numpydoc/
+ https://pypi.org/project/numpydoc/
+"
+SRC_URI="
+ https://github.com/numpy/numpydoc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/matplotlib-3.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=numpydoc::' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these require Internet (intersphinx)
+ numpydoc/tests/test_full.py::test_MyClass
+ numpydoc/tests/test_full.py::test_my_function
+ )
+ epytest --pyargs numpydoc
+}