summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-23 00:10:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-23 00:53:15 +0100
commitb0abaec4ce370bed8d71efb5982534aba8c74878 (patch)
tree0790ca126ceaa83c2289128354fb6a5d2ed40032 /dev-python/notebook
parentmedia-video/pipewire: bump to v0.3.24 (diff)
downloadgentoo-b0abaec4ce370bed8d71efb5982534aba8c74878.tar.gz
gentoo-b0abaec4ce370bed8d71efb5982534aba8c74878.tar.bz2
gentoo-b0abaec4ce370bed8d71efb5982534aba8c74878.zip
dev-python/notebook: Disable selenium tests harder
Closes: https://bugs.gentoo.org/777795 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/notebook')
-rw-r--r--dev-python/notebook/notebook-6.3.0.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/notebook/notebook-6.3.0.ebuild b/dev-python/notebook/notebook-6.3.0.ebuild
index 0ee849912ef9..79f3213aac14 100644
--- a/dev-python/notebook/notebook-6.3.0.ebuild
+++ b/dev-python/notebook/notebook-6.3.0.ebuild
@@ -58,8 +58,6 @@ python_prepare_all() {
python_test() {
local deselect=(
- # require geckodriver
- notebook/tests/selenium
# trash doesn't seem to work for us
notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_checkpoints_follow_file
notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_delete
@@ -73,7 +71,8 @@ python_test() {
notebook/services/kernels/tests/test_kernels_api.py::KernelCullingTest::test_culling
)
- epytest ${deselect[@]/#/--deselect }
+ # selenium tests require geckodriver
+ epytest --ignore notebook/tests/selenium ${deselect[@]/#/--deselect }
}
python_install() {