summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-12 07:24:25 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-12 07:38:57 +0200
commita6dc258b2d5d4c09683a7abd72f2d7e6fda6ce9c (patch)
tree894fc0e27d93ed4ead3da7f5c20b8929257b599d /dev-python/notebook
parentdev-python/tikzplotlib: Bump to 0.9.12 (diff)
downloadgentoo-a6dc258b2d5d4c09683a7abd72f2d7e6fda6ce9c.tar.gz
gentoo-a6dc258b2d5d4c09683a7abd72f2d7e6fda6ce9c.tar.bz2
gentoo-a6dc258b2d5d4c09683a7abd72f2d7e6fda6ce9c.zip
dev-python/notebook: Bump to 6.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/notebook')
-rw-r--r--dev-python/notebook/Manifest1
-rw-r--r--dev-python/notebook/notebook-6.4.3.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/notebook/Manifest b/dev-python/notebook/Manifest
index ce06dd4939a4..10100346246e 100644
--- a/dev-python/notebook/Manifest
+++ b/dev-python/notebook/Manifest
@@ -1,3 +1,4 @@
DIST notebook-6.4.0.tar.gz 13937270 BLAKE2B 41ba6e3dd22c92b6044199737fe93563aad07117e8c64817566765d643867b582218a1b34099acf2a84df9ac9f8eb2773f6f3e6779b14255867fd97ec443df85 SHA512 8bb57b3efaaddb781ee963a569996e45c563b50b2cb918fb7722805710dd5852d895ff5b5f5575686032a037d7395aa581140b471b529d68dfcb371841607481
DIST notebook-6.4.1.tar.gz 14139457 BLAKE2B 4be00ba6cd2f66873657f8ad5f79b444bbfbb978eaac7ddb57ef5da39a81c2746e7658004179e44aa98fa5fc5954b022b2e3c0c15dac0cc6da21b95a16225bfd SHA512 aa73e90f8ad1888f469e4cb412b6f17742e3b68ce429b2feaafeaeebbbb9e0cc437f3f73f26204b8de8367620ecb492033786c00b04d641ce0bfb4df75460419
DIST notebook-6.4.2.tar.gz 14133763 BLAKE2B 2c4f9677b014f484f7c975344f6e3aa29476b3b3bf2dd329ee527be653573f199c6d66078bc1f0787227414fb818df8df3d38e5f1bea9d3f2605f796a391cb37 SHA512 d9914c2924b7a0837295a7cfe2bdf551e1d71f35bab43bd6d12e798562c7e103f28cfdff6692e6ac5de394867071b8e1eae7a26bfd0a76b4a9304b7bea29f119
+DIST notebook-6.4.3.tar.gz 14344061 BLAKE2B a6d12df889015801a47061b40c320f659adda19cdf37832de1fd2b0257e7b1e22439aa4fd7663595c798b4b04c8c8e720a3799bcb20b93a0229ccf26622eee04 SHA512 14bb5c1a858c2d48f19f6a9907c4e3a053e77586a9ce78f3116752a02c39056bfa02fac5ef37404b742861a66751ca765b1d329a530b09752cf54fa464ab565b
diff --git a/dev-python/notebook/notebook-6.4.3.ebuild b/dev-python/notebook/notebook-6.4.3.ebuild
new file mode 100644
index 000000000000..892d3ca7cd84
--- /dev/null
+++ b/dev-python/notebook/notebook-6.4.3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/mathjax-2.4
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-5.3.4[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-4.2.0[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]"
+
+# sphinx 2+ seems to have a problem with its github plugin. temporarily adding
+# a version constraint.
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-5.7.0-no-mathjax.patch
+)
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # disable bundled mathjax
+ sed -i 's/^.*MathJax.*$//' bower.json || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local deselect=(
+ # trash doesn't seem to work for us
+ notebook/services/contents/tests/test_contents_api.py::APITest::test_checkpoints_follow_file
+ notebook/services/contents/tests/test_contents_api.py::APITest::test_delete
+ notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_checkpoints_follow_file
+ notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_delete
+ notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_delete_dirs
+ notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_delete_non_empty_dir
+ notebook/services/contents/tests/test_manager.py::TestContentsManager::test_delete
+ notebook/services/contents/tests/test_manager.py::TestContentsManagerNoAtomic::test_delete
+ # TODO
+ notebook/services/kernels/tests/test_kernels_api.py::KernelAPITest::test_connections
+ notebook/services/kernels/tests/test_kernels_api.py::AsyncKernelAPITest::test_connections
+ notebook/services/kernels/tests/test_kernels_api.py::KernelCullingTest::test_culling
+ )
+
+ # selenium tests require geckodriver
+ epytest --ignore notebook/tests/selenium ${deselect[@]/#/--deselect }
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ ln -sf \
+ "${EPREFIX}/usr/share/mathjax" \
+ "${D}$(python_get_sitedir)/notebook/static/components/MathJax" || die
+}
+
+pkg_preinst() {
+ # remove old mathjax folder if present
+ rm -rf "${EROOT}"/usr/lib*/python*/site-packages/notebook/static/components/MathJax || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}