summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-17 08:16:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-17 08:16:00 +0100
commit24d3da000076dc3b8684ae4a1f2bd46aa482f71c (patch)
treebd0810fbec5751209210f54dfdf9e82e04b5f0b7 /dev-python/mypy
parentdev-python/pyclipper: Enable py3.11 (diff)
downloadgentoo-24d3da000076dc3b8684ae4a1f2bd46aa482f71c.tar.gz
gentoo-24d3da000076dc3b8684ae4a1f2bd46aa482f71c.tar.bz2
gentoo-24d3da000076dc3b8684ae4a1f2bd46aa482f71c.zip
dev-python/mypy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/mypy-0.990.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 2998255573be..5184d494fba2 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,2 +1 @@
-DIST mypy-0.990.gh.tar.gz 2693855 BLAKE2B d4c4408c763e9e540c1680704b427d0bc41068d926742ab7b33d5f27a33156322d56aba0e56e5b1be44d197a1b44c6c5e552c44f44b77a590e01168361d5b97c SHA512 a503c9a18e808d49d404eeae5d8d7c20193bca1f07c198cc880538960904e72226545f1b72fef083599af40124dfb35326b70e69c1e5cf3fea8db3b46c930fee
DIST mypy-0.991.gh.tar.gz 2694440 BLAKE2B 857c991a17f5a0195d5c7db60e73427695b64d3c3181b26919ed40a2b825ef5e8f30890a4ca7a55b739087af47f025b1d324563f5ef5e2f58c363562ecc49365 SHA512 02663494700d4ab6d08ab2199a7a81ad144ed090774326ea8d418dec37faec6d3b078f1c3120b8b014a676d69d5dc4e9b528b759c2de086a18569016b28b00d5
diff --git a/dev-python/mypy/mypy-0.990.ebuild b/dev-python/mypy/mypy-0.990.ebuild
deleted file mode 100644
index 7856ca6807e9..000000000000
--- a/dev-python/mypy/mypy-0.990.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Optional static typing for Python"
-HOMEPAGE="
- http://www.mypy-lang.org/
- https://github.com/python/mypy/
- https://pypi.org/project/mypy/
-"
-SRC_URI="
- https://github.com/python/mypy/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# stubgen collides with this package: https://bugs.gentoo.org/585594
-RDEPEND="
- !dev-util/stubgen
- >=dev-python/psutil-4[${PYTHON_USEDEP}]
- >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
- <dev-python/typed-ast-2[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
- >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
- <dev-python/mypy_extensions-0.5.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
- >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
- >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
- >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/furo
-distutils_enable_tests pytest
-
-# this requires packaging a lot of type stubs
-export MYPY_USE_MYPYC=0
-
-python_test() {
- # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
- # fail with high COLUMNS values
- local -x COLUMNS=80
- epytest -n "$(makeopts_jobs)"
-}