summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-09 10:35:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-09 13:45:25 +0200
commit265f9c1d18f3c5481085db8f5bda0ef8770005e0 (patch)
treea5849a3ce996c888831072e3751c66e63589ea51 /dev-python/markupsafe
parentdev-python/multiprocess: Fix wheel tags / platform compatibility (diff)
downloadgentoo-265f9c1d18f3c5481085db8f5bda0ef8770005e0.tar.gz
gentoo-265f9c1d18f3c5481085db8f5bda0ef8770005e0.tar.bz2
gentoo-265f9c1d18f3c5481085db8f5bda0ef8770005e0.zip
dev-python/markupsafe: Make extension build failures fatal
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markupsafe')
-rw-r--r--dev-python/markupsafe/markupsafe-3.0.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/markupsafe/markupsafe-3.0.1.ebuild b/dev-python/markupsafe/markupsafe-3.0.1.ebuild
index 3b757c2b39b4..c18c91aff961 100644
--- a/dev-python/markupsafe/markupsafe-3.0.1.ebuild
+++ b/dev-python/markupsafe/markupsafe-3.0.1.ebuild
@@ -23,6 +23,11 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv
distutils_enable_tests pytest
+python_compile() {
+ local -x CIBUILDWHEEL=1
+ distutils-r1_python_compile
+}
+
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest