summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-03-09 11:41:13 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-03-09 11:58:49 -0600
commit93d697e989c9f65af087a79edda9ffabd362f6fa (patch)
treeedaa072e23033844276dff9dcc501b5366797da1 /dev-python/locustio
parentdev-python/kombu: allow renamed msgpack to be used (diff)
downloadgentoo-93d697e989c9f65af087a79edda9ffabd362f6fa.tar.gz
gentoo-93d697e989c9f65af087a79edda9ffabd362f6fa.tar.bz2
gentoo-93d697e989c9f65af087a79edda9ffabd362f6fa.zip
dev-python/locustio: allow usage of renamed msgpack
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/locustio')
-rw-r--r--dev-python/locustio/locustio-0.7.3-r1.ebuild (renamed from dev-python/locustio/locustio-0.7.3.ebuild)8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/locustio/locustio-0.7.3.ebuild b/dev-python/locustio/locustio-0.7.3-r1.ebuild
index 7892ab1e586c..4196e40e6d3b 100644
--- a/dev-python/locustio/locustio-0.7.3.ebuild
+++ b/dev-python/locustio/locustio-0.7.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -28,3 +28,9 @@ RDEPEND=">=dev-python/gevent-1.0.1[${PYTHON_USEDEP}]
python_test() {
esetup.py test
}
+
+python_prepare_all() {
+ # allow useage of renamed msgpack
+ sed -i '/^msgpack/d' setup.py || die
+ distutils-r1_python_prepare_all
+}