summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 16:18:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 16:43:42 +0100
commit70f46ece315b85b554816525f5c155cbd074e5da (patch)
tree914d5c0fc1207303dd841ccb701c525b255d552e /dev-python/liblarch
parentdev-python/jupyter: Switch to PEP 517 build (diff)
downloadgentoo-70f46ece315b85b554816525f5c155cbd074e5da.tar.gz
gentoo-70f46ece315b85b554816525f5c155cbd074e5da.tar.bz2
gentoo-70f46ece315b85b554816525f5c155cbd074e5da.zip
dev-python/liblarch: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/liblarch')
-rw-r--r--dev-python/liblarch/liblarch-3.1.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/liblarch/liblarch-3.1.0-r1.ebuild b/dev-python/liblarch/liblarch-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..ec59aa7d9a05
--- /dev/null
+++ b/dev-python/liblarch/liblarch-3.1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library to handle directed acyclic graphs"
+HOMEPAGE="https://wiki.gnome.org/Projects/liblarch"
+SRC_URI="https://github.com/getting-things-gnome/liblarch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}