summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-05 08:48:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-05 09:57:53 +0200
commitd3d0501ae09bfaba4c8a3380b8045b469d0d8551 (patch)
treefd80f8c4b976d701bdcddcc0fd859795b3074488 /dev-python/libarchive-c
parentdev-python/Nuitka: Bump to 1.7 (diff)
downloadgentoo-d3d0501ae09bfaba4c8a3380b8045b469d0d8551.tar.gz
gentoo-d3d0501ae09bfaba4c8a3380b8045b469d0d8551.tar.bz2
gentoo-d3d0501ae09bfaba4c8a3380b8045b469d0d8551.zip
dev-python/libarchive-c: Bump to 5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/libarchive-c')
-rw-r--r--dev-python/libarchive-c/Manifest1
-rw-r--r--dev-python/libarchive-c/libarchive-c-5.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/libarchive-c/Manifest b/dev-python/libarchive-c/Manifest
index fc8504389ded..cd628c924e62 100644
--- a/dev-python/libarchive-c/Manifest
+++ b/dev-python/libarchive-c/Manifest
@@ -1,2 +1,3 @@
DIST libarchive-c-4.0.gh.tar.gz 47743 BLAKE2B c6246b35a9a389c6cd999b32412436f8134737a4cba1c0bf8a905e3ba6e1653c515956f43a580901dd4278cbc00b783ecfa7a4306f0fc7ca2d2666b3af500cb8 SHA512 787b049a5f06d7370369a6bb2d9ebab6e4e5eda0a4f839906e205a7e19a00f9f7e350d4c42e3434e345063dd0ea44e5b0b4c0524033b05a6d8f15758757c5c36
DIST python-libarchive-c-4.0.gh.tar.gz 47727 BLAKE2B 87f8cfb0adf080b11df85d065fbcc38bf5682592882b3a8a8077e5cfb590cc10a05b98c98a2be41570aa59d06899b2e47815183e563007b1077717cdaa79a21c SHA512 1544713802789859ffa9a0d8f4e490f720bbd4d589aae8899d0d1fb6780f2cde0db96f3023c1c32eacea07ea325ac180797aebdb0e8e37093af53807f2e5c812
+DIST python-libarchive-c-5.0.gh.tar.gz 48751 BLAKE2B 2ab737c7493c202ba9a1ad57e1066aad12ea984bfa0e63115f59491ea14b3bd1d46d2bb20f033bf5bae64a6badf73b641183f63cc79c9f0e6141792a35521dc4 SHA512 df4758f4b7207fe77ae650aa78c302e9e2a0c7ba81fbeae70af8cb37789a056bc420acd73c1d5baec7b0e93a47fd3e5130db8e43c983f4723366f75a58823f75
diff --git a/dev-python/libarchive-c/libarchive-c-5.0.ebuild b/dev-python/libarchive-c/libarchive-c-5.0.ebuild
new file mode 100644
index 000000000000..c82a0dc6a681
--- /dev/null
+++ b/dev-python/libarchive-c/libarchive-c-5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-libarchive-c-${PV}
+DESCRIPTION="A Python interface to libarchive"
+HOMEPAGE="
+ https://github.com/Changaco/python-libarchive-c/
+ https://pypi.org/project/libarchive-c/
+"
+SRC_URI="
+ https://github.com/Changaco/python-libarchive-c/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-arch/libarchive
+"
+
+distutils_enable_tests pytest