summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-17 15:09:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-17 15:35:20 +0200
commit1b36a59e9767a777a77089f22ca1f10ed718ce67 (patch)
tree1ee7ea062286645a337107fbe078c5cd59850fc2 /dev-python/jsonpath-ng
parentdev-python/djangorestframework: Enable py3.12 (diff)
downloadgentoo-1b36a59e9767a777a77089f22ca1f10ed718ce67.tar.gz
gentoo-1b36a59e9767a777a77089f22ca1f10ed718ce67.tar.bz2
gentoo-1b36a59e9767a777a77089f22ca1f10ed718ce67.zip
dev-python/jsonpath-ng: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpath-ng')
-rw-r--r--dev-python/jsonpath-ng/Manifest1
-rw-r--r--dev-python/jsonpath-ng/jsonpath-ng-1.6.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jsonpath-ng/Manifest b/dev-python/jsonpath-ng/Manifest
index 74e5acdda5c9..dc1741b93b09 100644
--- a/dev-python/jsonpath-ng/Manifest
+++ b/dev-python/jsonpath-ng/Manifest
@@ -1 +1,2 @@
DIST jsonpath-ng-1.5.3.tar.gz 32819 BLAKE2B 2f217638a5f4b76d0fe2bd8d0655794281d437983abe9fda96a40440bc97ba0ad13875b7cf83d06386258c43e66732b8a9d799ccaecf5034a9d01d120f403cb6 SHA512 adf501d0db74f76216476700dce342d7a92641ecb451bdce43d0c6abce59a278dc1696b959205030de256b456ae67a554ea35a5dec272f0a4fc84c4d2b76a5c1
+DIST jsonpath-ng-1.6.0.tar.gz 37132 BLAKE2B 5af13db8ab85482656d5c1501edfb2c61dc62a08a2c90a12a7ba7b141b538b5ebfca86c856b9f65ef1c1b82329eb0ed7db5c1890d881e4cb968cb6ca31ddeb6f SHA512 46eefe57330887143b98ef4deb97c5d7242f0cfbd923dffc17bd4147326ea4333c76df2451fbbb27933ada872628ad1ec04bdb9fc8e2c288c89bf37ec3783c43
diff --git a/dev-python/jsonpath-ng/jsonpath-ng-1.6.0.ebuild b/dev-python/jsonpath-ng/jsonpath-ng-1.6.0.ebuild
new file mode 100644
index 000000000000..f5685da526e8
--- /dev/null
+++ b/dev-python/jsonpath-ng/jsonpath-ng-1.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{11..2} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python JSONPath Next-Generation"
+HOMEPAGE="
+ https://github.com/h2non/jsonpath-ng/
+ https://pypi.org/project/jsonpath-ng/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/oslotest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest