summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-07-24 23:29:36 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2020-07-24 23:30:38 +0200
commita11a0b54fc27568999b9a7e3a822fe05c4cf4264 (patch)
tree91da60275859d11607848e3b83e0acbf4f677682 /dev-python/jikanpy
parentcmake*.eclass: Hardcode CMAKE_FIND_LIBRARY_CUSTOM_LIB_SUFFIX for riscv (diff)
downloadgentoo-a11a0b54fc27568999b9a7e3a822fe05c4cf4264.tar.gz
gentoo-a11a0b54fc27568999b9a7e3a822fe05c4cf4264.tar.bz2
gentoo-a11a0b54fc27568999b9a7e3a822fe05c4cf4264.zip
dev-python/jikanp: 4.2.1 version bump.
Ebuild has been switched to github as tarball source, since the tarball at pypi lacks CHANGELOG.md making setup.py crash during installation. Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'dev-python/jikanpy')
-rw-r--r--dev-python/jikanpy/Manifest1
-rw-r--r--dev-python/jikanpy/jikanpy-4.2.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jikanpy/Manifest b/dev-python/jikanpy/Manifest
index e6fa5a02ca75..1a37bd652132 100644
--- a/dev-python/jikanpy/Manifest
+++ b/dev-python/jikanpy/Manifest
@@ -1 +1,2 @@
DIST jikanpy-3.4.2.tar.gz 14132 BLAKE2B 4a06cd0ac37968c26cf062c7aa7b42a23795f372a814641d373097e67c0958ea2e640b9945883552c6997285fb3d19991482ed4872c5c74097940121edddca4d SHA512 cff23a20a331da55036875c2ea34e3bcf7c28592b625bb9c3fc453969db2f232cd30841757ec8d75807f323a2caa0f591f91e71547b29d07694560462c561d30
+DIST jikanpy-4.2.1.tar.gz 536588 BLAKE2B f6bf531cc57814d2740e1d325bc521dc92651a1a467b65277086130d9c00de7b592e81a7f82e12cb35ac8d8c7f1bcc6201f945ab9c49befb8b89093e627eacc1 SHA512 7f690745a790836ddae95aaffdaa59ea60d0c2b2d9c64be7548372719c826239d3d650931652ca75d8e35f1d4354c0b80ebf0d7e80a4fa4b65ec3bbd4bef1cd5
diff --git a/dev-python/jikanpy/jikanpy-4.2.1.ebuild b/dev-python/jikanpy/jikanpy-4.2.1.ebuild
new file mode 100644
index 000000000000..a901c883c33e
--- /dev/null
+++ b/dev-python/jikanpy/jikanpy-4.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for jikan.moe API."
+HOMEPAGE="https://pypi.org/project/jikanpy/"
+SRC_URI="https://github.com/abhinavk99/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+"