summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-07 09:10:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-07 10:26:37 +0100
commitfc3c502e22b2730aed9f5436182aa0ae9a89845c (patch)
treea12603dda5898aeb49c467ce05b0ebe61f023d71 /dev-python/jaraco-itertools
parentdev-python/jaraco-functools: Use pypi.eclass (diff)
downloadgentoo-fc3c502e22b2730aed9f5436182aa0ae9a89845c.tar.gz
gentoo-fc3c502e22b2730aed9f5436182aa0ae9a89845c.tar.bz2
gentoo-fc3c502e22b2730aed9f5436182aa0ae9a89845c.zip
dev-python/jaraco-itertools: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-itertools')
-rw-r--r--dev-python/jaraco-itertools/jaraco-itertools-6.2.1.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/jaraco-itertools/jaraco-itertools-6.2.1.ebuild b/dev-python/jaraco-itertools/jaraco-itertools-6.2.1.ebuild
index 9351e8966bb8..cee7045361a9 100644
--- a/dev-python/jaraco-itertools/jaraco-itertools-6.2.1.ebuild
+++ b/dev-python/jaraco-itertools/jaraco-itertools-6.2.1.ebuild
@@ -6,13 +6,12 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{9..11} )
-inherit distutils-r1
+inherit distutils-r1 pypi
-MY_P=${P/-/.}
DESCRIPTION="Tools for working with iterables. Complements itertools and more_itertools"
HOMEPAGE="https://github.com/jaraco/jaraco.itertools"
-SRC_URI="mirror://pypi/${MY_P::1}/${PN/-/.}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
+SRC_URI="$(pypi_sdist_url "${PN/-/.}")"
+S=${WORKDIR}/${P/-/.}
LICENSE="MIT"
SLOT="0"
@@ -28,8 +27,6 @@ BDEPEND="
distutils_enable_tests pytest
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
python_test() {
# create a pkgutil-style __init__.py in order to fix pytest's
# determination of package paths