summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 15:02:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 15:11:37 +0200
commit34650ea2c5f0b04ef40b7dbc417ac8b1f56390dd (patch)
tree38d7dfcc0aa17dfb8976884f1a6daa59ca2b3d70 /dev-python/iso8601/iso8601-0.1.12-r1.ebuild
parentdev-python/idna: Remove python2 (diff)
downloadgentoo-34650ea2c5f0b04ef40b7dbc417ac8b1f56390dd.tar.gz
gentoo-34650ea2c5f0b04ef40b7dbc417ac8b1f56390dd.tar.bz2
gentoo-34650ea2c5f0b04ef40b7dbc417ac8b1f56390dd.zip
dev-python/iso8601: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/iso8601/iso8601-0.1.12-r1.ebuild')
-rw-r--r--dev-python/iso8601/iso8601-0.1.12-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/iso8601/iso8601-0.1.12-r1.ebuild b/dev-python/iso8601/iso8601-0.1.12-r1.ebuild
new file mode 100644
index 000000000000..a13c32ae5c5b
--- /dev/null
+++ b/dev-python/iso8601/iso8601-0.1.12-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple module to parse ISO 8601 dates"
+HOMEPAGE="https://pypi.org/project/iso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+
+distutils_enable_tests pytest