summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-28 06:11:11 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-28 06:27:49 +0200
commit53c2118cc7ce1db7c157a4a1926d62ed72888646 (patch)
tree84db43d6b9c75fadd8b00447080df76f665c1e92 /dev-python/hypercorn
parentdev-python/prompt-toolkit: Bump to 3.0.44 (diff)
downloadgentoo-53c2118cc7ce1db7c157a4a1926d62ed72888646.tar.gz
gentoo-53c2118cc7ce1db7c157a4a1926d62ed72888646.tar.bz2
gentoo-53c2118cc7ce1db7c157a4a1926d62ed72888646.zip
dev-python/hypercorn: Bump to 0.17.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypercorn')
-rw-r--r--dev-python/hypercorn/Manifest1
-rw-r--r--dev-python/hypercorn/hypercorn-0.17.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/hypercorn/Manifest b/dev-python/hypercorn/Manifest
index 3f70248adae6..344c972003c9 100644
--- a/dev-python/hypercorn/Manifest
+++ b/dev-python/hypercorn/Manifest
@@ -1 +1,2 @@
DIST hypercorn-0.16.0.gh.tar.gz 159038 BLAKE2B d17fde74af7f3a0157af22465f52a46967b8c4297eb5f602614d5337ca511d365e391630495535b56650fc4bfac864d30c5b281c04beddb0fec9bfcecd0f0c00 SHA512 75d75f0a0c1726b83d8ee38d5a15f4241130369904c9925cc3b87d1bf92f0d6a59ae7e7c83434c60ceae4bb628f6a51a42eda00c68a226c0bea6ef1c6fb8cb2c
+DIST hypercorn-0.17.2.gh.tar.gz 162107 BLAKE2B f5db0c323c6bbf4dbb7d28617adf1a55fa810e165129d945b410e6810c8f0cc41c6dd8043f846f00405d56760ad94b807b53b104a97396277d98c33d6598b7d6 SHA512 c840eb34fb6e12c236c1d279ba94752a3a1d9ba3f73e519ff71628a648580e7ef6196f5f806053c601531b12af11aa455801a6c2c13cabf3729e55581ffbb881
diff --git a/dev-python/hypercorn/hypercorn-0.17.2.ebuild b/dev-python/hypercorn/hypercorn-0.17.2.ebuild
new file mode 100644
index 000000000000..9a7296e4811f
--- /dev/null
+++ b/dev-python/hypercorn/hypercorn-0.17.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A ASGI Server based on Hyper libraries and inspired by Gunicorn"
+HOMEPAGE="
+ https://github.com/pgjones/hypercorn/
+ https://pypi.org/project/Hypercorn/
+"
+SRC_URI="
+ https://github.com/pgjones/hypercorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/h11[${PYTHON_USEDEP}]
+ >=dev-python/h2-3.1.0[${PYTHON_USEDEP}]
+ dev-python/priority[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.1.0[${PYTHON_USEDEP}]
+ dev-python/taskgroup[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/wsproto-0.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--no-cov-on-fail::' pyproject.toml || die
+ distutils-r1_src_prepare
+}