summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-23 06:04:10 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-23 06:08:12 +0100
commit1f15c58a10523a4a1487a0373e16b00f1c47a9f5 (patch)
treed1da119c97b38cd72232183f62f59e940e200e3d /dev-python/hpack
parentdev-python/xlsxwriter: Bump to 3.2.1 (diff)
downloadgentoo-1f15c58a10523a4a1487a0373e16b00f1c47a9f5.tar.gz
gentoo-1f15c58a10523a4a1487a0373e16b00f1c47a9f5.tar.bz2
gentoo-1f15c58a10523a4a1487a0373e16b00f1c47a9f5.zip
dev-python/hpack: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hpack')
-rw-r--r--dev-python/hpack/Manifest1
-rw-r--r--dev-python/hpack/hpack-4.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/hpack/Manifest b/dev-python/hpack/Manifest
index 6b5558390e71..e2ba26734491 100644
--- a/dev-python/hpack/Manifest
+++ b/dev-python/hpack/Manifest
@@ -1 +1,2 @@
DIST hpack-4.0.0.gh.tar.gz 5301419 BLAKE2B 0164f6aafc0d1f17f6c397efe710503a22501faae3c7dbba4e57ca2dc76e4d373bc5e65bf55acda8bc61975d12f8a2084de0e0c4587539e5a3102e3cf66d562b SHA512 f482d086d7a82649393e3cfea55c98966ce57055cb1826bc4dec1ea334661c02708e7903f2e8e588ee1c30df41373e1de9fb960c2e7bbc18d0ace0b8f97b195b
+DIST hpack-4.1.0.gh.tar.gz 5303243 BLAKE2B 3394c4142f5fdb32fb466e96ee96be7a41fc867a5731b73338262498538d6f7d47c2864c4b8391b599001e996fc1218dec1e4c1dbda325e90248a265161ec463 SHA512 10018fefae7e09078c0133a3519f18f72bd39f31d652f224d2ca2a780e2f18c51c7fc4589ae540e3130909a6b3878e0ac2ce8a5dadc98ce93bcf8af201989544
diff --git a/dev-python/hpack/hpack-4.1.0.ebuild b/dev-python/hpack/hpack-4.1.0.ebuild
new file mode 100644
index 000000000000..a7a8da6f2650
--- /dev/null
+++ b/dev-python/hpack/hpack-4.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="
+ https://python-hyper.org/projects/hpack/en/latest/
+ https://github.com/python-hyper/hpack/
+ https://pypi.org/project/hpack/
+"
+# PyPI sdist is missing test fixtures, as of 4.0.0
+SRC_URI="
+ https://github.com/python-hyper/hpack/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest