summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-20 03:36:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-20 03:36:50 +0200
commit5d0876ad6ac8158595026449775254ced0f1be02 (patch)
tree8f6e45caef1a5faec59d176eddfd3b96bedf9995 /dev-python/gsd
parentdev-python/gsd: Remove old (diff)
downloadgentoo-5d0876ad6ac8158595026449775254ced0f1be02.tar.gz
gentoo-5d0876ad6ac8158595026449775254ced0f1be02.tar.bz2
gentoo-5d0876ad6ac8158595026449775254ced0f1be02.zip
dev-python/gsd: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-3.3.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index ddcac2efa72a..65f07eb5a849 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-3.3.0.tar.gz 108961 BLAKE2B 1f734534717af776ebb5a62ddf67eabcc5bc99a814e48ac8d962fc034f24e4eb87a3e45087f3e2f7db757bfd57e44668e41a3ca1fccf406d964024a3a2d399ae SHA512 f01017f46626d19ae5e5bf683c719d6f74b0f3a9d295cd2e54d736f8ca9c25740389b9701b636b2513039919d52e6a6193215cdf759c1f5d3e686071c3888c27
+DIST gsd-3.3.1.tar.gz 108613 BLAKE2B fdfc1e0e70f9b3d804ec5b7a76263b077609af811c9bb1cddf304ff46701d710fead5f103b712cd408cf3c4aa19b91e5af208d586e8a9ca81b56452e2ba32587 SHA512 84a131e4ac6baa7258ed7be5886b99fb34421e919eeaddadf658c3d0a40e2c3667b7ecee8c10a4e3b264538ebfd34c5b97090b23c72c7f9ada5c6b76985b894d
diff --git a/dev-python/gsd/gsd-3.3.1.ebuild b/dev-python/gsd/gsd-3.3.1.ebuild
new file mode 100644
index 000000000000..a16117a836ec
--- /dev/null
+++ b/dev-python/gsd/gsd-3.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}