summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-10 20:51:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-10 20:52:40 +0200
commitdd0a9e0334915f5b03a2b438e7ac6917ac940aa5 (patch)
tree1f335a4705d2a0720716e7a1e31d42fe4e8d081a /dev-python/gpep517
parentdev-python/google-auth: Remove old (diff)
downloadgentoo-dd0a9e0334915f5b03a2b438e7ac6917ac940aa5.tar.gz
gentoo-dd0a9e0334915f5b03a2b438e7ac6917ac940aa5.tar.bz2
gentoo-dd0a9e0334915f5b03a2b438e7ac6917ac940aa5.zip
dev-python/gpep517: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gpep517')
-rw-r--r--dev-python/gpep517/gpep517-6.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/gpep517/gpep517-6.ebuild b/dev-python/gpep517/gpep517-6.ebuild
deleted file mode 100644
index 8dfcfc0113db..000000000000
--- a/dev-python/gpep517/gpep517-6.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=manual
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
-HOMEPAGE="
- https://pypi.org/project/gpep517/
- https://github.com/mgorny/gpep517/
-"
-SRC_URI="
- https://github.com/mgorny/gpep517/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-# do not use any build system to avoid circular deps
-python_compile() { :; }
-
-python_install() {
- python_domodule gpep517
- python_newscript - gpep517 <<-EOF
- #!${EPREFIX}/usr/bin/python
- import sys
- from gpep517.__main__ import main
- sys.exit(main())
- EOF
-}