summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-12 07:41:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-12 07:50:35 +0200
commit02fc5a570089fb2ff82e3272cbb5701723c98b81 (patch)
tree10e6fde2bc30d7d970c443d9ff33262b7cb867b5 /dev-python/google-auth-oauthlib
parentdev-python/mkdocs-material: Bump to 9.3.1 (diff)
downloadgentoo-02fc5a570089fb2ff82e3272cbb5701723c98b81.tar.gz
gentoo-02fc5a570089fb2ff82e3272cbb5701723c98b81.tar.bz2
gentoo-02fc5a570089fb2ff82e3272cbb5701723c98b81.zip
dev-python/google-auth-oauthlib: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-1.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 781dfd77a4f7..0239e1ee653c 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1 +1,2 @@
DIST google-auth-library-python-oauthlib-1.0.0.gh.tar.gz 71294 BLAKE2B f0f085ffbec620106f5e7ead56085cee4642932a0fea1bfeec01d1f3b77a8d97aa4e6cdbc29c303abebb30e1994de86cfbb6a950bb34fc243dd312b251afc5da SHA512 74eef43e4ce8de55170c7362eaddcd796c683b3d361d52ff02db1f74b301f12e57f0acb2b52fcc5a6e661b47e3066a780915955b8d933314646483b43c8c5b68
+DIST google-auth-library-python-oauthlib-1.1.0.gh.tar.gz 71790 BLAKE2B 0d30bcb076c53052ef1a5d75276266bbbd08940953589b73c370ce66f7f20f4b47d27be8f39bfcfcd109dc7c9e7c39ddfebc65aef4953f168493ad3decdd87dd SHA512 43cd5034ed73b6509861a85abe4090f03499a98de7d88a88adf976fb33e813d31fac067ce25257b540ef71794b0d6faf7dea3c9125c0ae4468a9b2b1ba7994c4
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.1.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.1.0.ebuild
new file mode 100644
index 000000000000..395c2d95e16a
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest