summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/gevent-websocket
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/gevent-websocket')
-rw-r--r--dev-python/gevent-websocket/Manifest2
-rw-r--r--dev-python/gevent-websocket/gevent-websocket-0.9.3.ebuild21
-rw-r--r--dev-python/gevent-websocket/gevent-websocket-0.9.5.ebuild21
-rw-r--r--dev-python/gevent-websocket/metadata.xml22
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/gevent-websocket/Manifest b/dev-python/gevent-websocket/Manifest
new file mode 100644
index 000000000000..aa1589af29e0
--- /dev/null
+++ b/dev-python/gevent-websocket/Manifest
@@ -0,0 +1,2 @@
+DIST gevent-websocket-0.9.3.tar.gz 16463 SHA256 6475220340f9f8895a0f51bd2b9df3511bc7765dc055f49e997584bdaee3381f SHA512 71d6a81f04bae36e7122890b37082df188c28f5901bffcd8c774b2bf1cbcc603ff7ff9f854ab17ef00564d36b19787e3a9267e6e299f9837c1d682e63acadb73 WHIRLPOOL 27f84f0452b5be4cc0da03fb5e38710ce7fa3be052c1e41c4b9bc87a7aef40a13c714c24444a681b755eaeaa91e614aff92cb95b49fb03e004f8d44751a5737c
+DIST gevent-websocket-0.9.5.tar.gz 16970 SHA256 0091d6e6aa7298510cadcccb8068e1097a50d4e19090d0c055a93068d4530056 SHA512 fdaa8c704e1d0869700cf67c3a1c04246bfd816f98beac9c755b723a2074aa26344991c924ebdd7de5661065cde48ad412685014c53fdb92df12401cad3c358c WHIRLPOOL f566ec09f2d7739b0f70600c684471b768756c4b94b0462979ba770c5a17bc984b47e2ceb7ca1c0cf2ad26fa9fd9284326294450f013cd43fa243e7140aa7285
diff --git a/dev-python/gevent-websocket/gevent-websocket-0.9.3.ebuild b/dev-python/gevent-websocket/gevent-websocket-0.9.3.ebuild
new file mode 100644
index 000000000000..87a025043a00
--- /dev/null
+++ b/dev-python/gevent-websocket/gevent-websocket-0.9.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Websocket handler for the gevent pywsgi server"
+HOMEPAGE="http://pypi.python.org/pypi/gevent-websocket/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/gevent[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/gevent-websocket/gevent-websocket-0.9.5.ebuild b/dev-python/gevent-websocket/gevent-websocket-0.9.5.ebuild
new file mode 100644
index 000000000000..edcf9042b6a9
--- /dev/null
+++ b/dev-python/gevent-websocket/gevent-websocket-0.9.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Websocket handler for the gevent pywsgi server"
+HOMEPAGE="http://pypi.python.org/pypi/gevent-websocket/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/gevent[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/gevent-websocket/metadata.xml b/dev-python/gevent-websocket/metadata.xml
new file mode 100644
index 000000000000..6f1ce8d98ff4
--- /dev/null
+++ b/dev-python/gevent-websocket/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>ultrabug@gentoo.org</email>
+ <name>Ultrabug</name>
+ <description>main maintainer</description>
+</maintainer>
+<maintainer>
+ <email>julien@thebault.co</email>
+ <name>Lujeni</name>
+ <description>Proxy Maintainer. CC on bugs</description>
+</maintainer>
+<longdescription>
+ Websocket handler for the gevent pywsgi server
+</longdescription>
+<upstream>
+ <remote-id type="pypi">gevent-websocket</remote-id>
+</upstream>
+</pkgmetadata>